當前位置:首頁 » 操作系統 » 時間源碼

時間源碼

發布時間: 2022-01-09 03:39:14

A. 時間代碼的網站是多少

什麼意思??時間代碼的網站???

B. 日期+時間代碼!!!

<script>
function getDate(){
var d = new Date();
var year = d.getYear();
var month = d.getMonth()+1;
var date = d.getDate();
document.write(year+"年"+month+"月"+date+"日");

}
function getTime(){
var t=new Date();
var hour=t.getHours();
var minutie=t.getMinutes();
var second=t.getSeconds();
document.write(hour+"時" +minutie+"分"+second+"秒")
}
getDate();
getTime();
</script>

C. 求一個標准北京時間的源代碼,只要時間不要日期的,我要插入到自己的網頁!

<script language="javaScript"> <!-- function get_time(){ var date = new Date(); var year = "", month = "", day = "", week = "", hour = "", minute = "", second = ""; year = date.getYear(); month = add_zero(date.getMonth() + 1); day = add_zero(date.getDate()); week = date.getDay(); switch (date.getDay()){ case 0: val = "星期天"; break case 1: val = "星期一"; break case 2: val = "星期二"; break case 3: val = "星期三"; break case 4: val = "星期四"; break case 5: val = "星期五"; break case 6: val = "星期六"; break } hour = add_zero(date.getHours()); minute = add_zero(date.getMinutes()); second = add_zero(date.getSeconds()); time_div.innerText = hour + ":" + minute + ":" + second ; } function add_zero(temp){ if(temp < 10) return "0" + temp; else return temp; } setInterval("get_time()", 1000); //--> </script> <font class="w12"><b> <div id="time_div"></div> </b></font>

D. 時間代碼

<td valign="top" class="redfont red"><script language="javascript">
function showTime(){
var oDiv = document.all('oDiv');
var oDate = new Date();
var strTime = oDate.getFullYear() + '年' + eval(oDate.getMonth()+1) + '月' + oDate.getDate() + '日 星期' + '日一二三四五六'.substr(oDate.getDay(),1) + ' ' + oDate.getHours() + ':' + oDate.getMinutes() + ':' + oDate.getSeconds();
oDiv.innerHTML = strTime;
window.setTimeout('showTime()', 1000);
}
window.onload = showTime;
</script>
<div id="oDiv" style="color:#33FF66;"></div></td>

E. 網頁時間代碼

<table width="96%" border="0" cellspacing="0" cellpadding="0">
<tr>
<td width="22%" class="redfont red"><div align="center">今天是:</div></td>
<td width="78%" class="redfont red"><script language="javascript">
function showTime(){
var oDiv = document.all('oDiv');
var oDate = new Date();
var strTime = oDate.getFullYear() + '年' + eval(oDate.getMonth()+1) + '月' + oDate.getDate() + '日星期' + '日一二三四五六'.substr(oDate.getDay(),1) + '' + oDate.getHours() + ':' + oDate.getMinutes() + ':' + oDate.getSeconds();
oDiv.innerHTML = strTime;
window.setTimeout('showTime()', 1000);
}
window.onload = showTime;
</script>
<div id="oDiv"></div></td>
</tr>
</table>

F. 求易語言北京時間源碼

.版本 2
.支持庫 internet

.程序集 窗口程序集1

.子程序 _按鈕1_被單擊

取網路時間 ()

.子程序 取網路時間, 日期時間型
.參數 是否改系統時間, 邏輯型, 可空, 是否立即修改系統時間為網路上取到的時間
.局部變數 網頁地址, 文本型, , , 如果空
.局部變數 前導字元, 文本型, , , 這是取網頁文本中的日期前的一些文字
.局部變數 文本1, 文本型
.局部變數 首位置, 整數型
.局部變數 臨時保存時間, 日期時間型
.局部變數 相差的時間, 整數型
.局部變數 年月日, 文本型
.局部變數 時, 整數型
.局部變數 分, 整數型
.局部變數 秒, 整數型
.局部變數 結果時間, 日期時間型

臨時保存時間 = 取現行時間 () ' 取啟動時的時間,因為啟動後讀網頁會浪費一些時間,這樣取出的不準.這是為了較准用的.
網頁地址 = 「http://www.time.ac.cn/stime.asp」
輸出調試文本 (網頁地址)
' 處理事件 () '這里網路不通時可能會死掉!!!
文本1 = 到文本 (HTTP讀文件 (網頁地址))
' ===================================================
前導字元 = 「document.write('20」 ' 因為是21世紀,所以取到20,這樣一百年夠用了,而且是唯一的字串.
首位置 = 尋找文本 (文本1, 前導字元, 1, 假)
.如果真 (首位置 ≥ 1)
首位置 = 首位置 + 取文本長度 (前導字元)
.如果真結束
年月日 = 取文本中間 (文本1, 首位置 - 2, 14) ' 這里的是連在一起的,就一起取吧.
年月日 = 子文本替換 (年月日, 「'」, 「」, , , 真) ' 去昝最後尾的一個'符號
輸出調試文本 (到文本 (首位置) + 「 年月日 」 + 年月日)
結果時間 = 到時間 (年月日)
輸出調試文本 (到文本 (首位置) + 「 年月日 」 + 到文本 (結果時間))
' ===================================================

前導字元 = 「var hrs = 」
首位置 = 尋找文本 (文本1, 前導字元, 1, 假)
.如果真 (首位置 ≥ 1)
首位置 = 首位置 + 取文本長度 (前導字元)
.如果真結束
時 = 到數值 (取文本中間 (文本1, 首位置, 2))
輸出調試文本 (到文本 (首位置) + 「 時 」 + 到文本 (時))

前導字元 = 「var min = 」
首位置 = 尋找文本 (文本1, 前導字元, 1, 假)
.如果真 (首位置 ≥ 1)
首位置 = 首位置 + 取文本長度 (前導字元)
.如果真結束
分 = 到數值 (取文本中間 (文本1, 首位置, 2))
輸出調試文本 (到文本 (首位置) + 「 分 」 + 到文本 (分))

前導字元 = 「var sec = 」
首位置 = 尋找文本 (文本1, 前導字元, 1, 假)
.如果真 (首位置 ≥ 1)
首位置 = 首位置 + 取文本長度 (前導字元)
.如果真結束
秒 = 到數值 (取文本中間 (文本1, 首位置, 2))
輸出調試文本 (到文本 (首位置) + 「 秒 」 + 到文本 (秒))

' ===================================================
相差的時間 = 取時間間隔 (取現行時間 (), 臨時保存時間, #秒) ' 因為啟動後讀網頁會浪費一些時間,這樣取出的不準.這是為了較准用的.
輸出調試文本 (取時間間隔 (取現行時間 (), 臨時保存時間, #秒)) ' 讀網頁使用了幾秒鍾,這個時間要扣回來
結果時間 = 增減時間 (到時間 (年月日 + 到文本 (時) + 「時」 + 到文本 (分) + 「分」 + 到文本 (秒) + 「秒」), #秒, 相差的時間)
.如果真 (是否改系統時間 = 真)
置現行時間 (結果時間)
.如果真結束
返回 (結果時間)

G. 怎麼弄時間代碼

<span id=liveclock style=position:absolute;left:312px;top:181px;; width: 109px; height: 15px>
</span>
<script language=javascript>

<!--

function show5(){if(!document.layers&&!document.all)

return

var Digital=new Date()

var hours=Digital.getHours()

var minutes=Digital.getMinutes()

var seconds=Digital.getSeconds()

var dn="AM"

if(hours>12){dn="PM"

hours=hours-12

}if(hours==0)

hours=12

if(minutes<=9)

minutes="0"+minutes

if(seconds<=9)

seconds="0"+seconds

//change font size here to your desire

myclock="<font size='5' face='Arial' ><b><font size='1'>Current Time:</font></br>"+hours+":"+minutes+":"

+seconds+" "+dn+"</b></font>"

if(document.layers){document.layers.liveclock.document.write(myclock)

document.layers.liveclock.document.close()

}else if(document.all)

liveclock.innerHTML=myclock

setTimeout("show5()",1000)

}

//-->

</script>
<script language="JavaScript">

<!-- hide

function goHist(a)

{

history.go(a);

}

//-->

</script>

把<body>中的內容改為

<body bgcolor="#ffffff" ONLOAD=show5()>

H. 標准時間代碼

<!-- 在表單中顯示當前時間 -->

<!--把以下代碼至你的html文件的<body>和</body>之間-->
<script>
<!-- Hide
var timerID = null
var timerRunning = false
function MakeArray(size)
{
this.length = size;
for(var i = 1; i <= size; i++)
{
this[i] = "";
}
return this;
}
function stopclock (){
if(timerRunning)
clearTimeout(timerID);
timerRunning = false
}
function showtime () {
var now = new Date();
var year = now.getYear();
var month = now.getMonth() + 1;
var date = now.getDate();
var hours = now.getHours();
var minutes = now.getMinutes();
var seconds = now.getSeconds();
var day = now.getDay();
Day = new MakeArray(7);
Day[0]="SUN";
Day[1]="MON";
Day[2]="TUE";
Day[3]="WED";
Day[4]="THU";
Day[5]="FRI";
Day[6]="SAT";
var timeValue = "";
timeValue += (Day[day]) + " ";
timeValue += ((month < 10) ? " 0" : " ") + month + "-";
timeValue += date + "-" + year + " ";
timeValue += ((hours <= 12) ? hours : hours - 12);
timeValue += ((minutes < 10) ? ":0" : ":") + minutes;
timeValue += ((seconds < 10) ? ":0" : ":") + seconds;
timeValue += (hours < 12) ? " AM" : " PM";
document.jsfrm.face.value = timeValue;
timerID = setTimeout("showtime()",1000);
timerRunning = true
}
function startclock () {
stopclock();
showtime()
}
//-->
</script>

<BODY onLoad="startclock();">
<FORM NAME='jsfrm'>
<INPUT TYPE=text NAME='face' size=35 value=''>
</form>

補充:
首先要理解客戶端和伺服器
js是運行在客戶端機子上的一種腳本程序,而這個顯示時間的代碼是獲取的客戶端主機上的時間,即你瀏覽一個網頁時,上面顯示的是你機子的系統時間,你機子的系統時間改變了,那它顯示的時間也會隨著變化。
而用asp,jsp等動態的網頁編程就可以獲取伺服器的時間,所以當你瀏覽這種網頁時,不管你的機子上是時間怎麼變,它都會顯示的是遠程伺服器的時間,這也許就是你理解的「我要的是一個可以顯示真正的背景時間的代碼,就算你把本機時間改了,這個頁面上的時間也不會變的」。
所以用js不能實現的,不過沒人用asp,jsp等獲取伺服器的時間來顯示到客戶端,當很多人同時瀏覽時,樣對伺服器的壓力很大,所以基本上看不到有樓主所說的那種情況,因為動態網站裡面不會用它

I. 時間表的源代碼是什麼

那要看你用什麼語言的寫的吧

J. html時間代碼

<script>
var d = new Date();
document.write(d.getHours() +":"+d.getMinutes());
</script>

註:
new Date()是創建一個日期對象,裡麵包含了年月日時分秒和毫秒
getHours()方法是取得小時數,getMinutes()是取得分鍾數

熱點內容
mysql資料庫的語句 發布:2024-02-23 14:37:08 瀏覽:8
tlq伺服器是什麼意思 發布:2024-02-23 14:32:18 瀏覽:450
c語言搜索 發布:2024-02-23 14:16:12 瀏覽:372
javarsa密鑰對 發布:2024-02-23 14:11:31 瀏覽:222
國產安卓哪個系統最好 發布:2024-02-23 13:59:03 瀏覽:535
我們家裡的網路密碼是多少 發布:2024-02-23 13:50:24 瀏覽:903
it培訓java 發布:2024-02-23 13:49:43 瀏覽:997
編程布置 發布:2024-02-23 13:18:36 瀏覽:477
浪潮伺服器怎麼開機 發布:2024-02-23 12:33:37 瀏覽:662
聯想更新配置在哪個文件里 發布:2024-02-23 12:28:32 瀏覽:846