當前位置:首頁 » 存儲配置 » 2k交換機怎麼配置trunk

2k交換機怎麼配置trunk

發布時間: 2022-11-29 21:32:22

㈠ Huawei的交換機如何配置trunk

配置環境參數】x0dx0a1. SwitchA 埠E0/1屬於vlan10,E0/2屬於vlan20,E0/3與SwitchB埠E0/3互連x0dx0a2. SwitchB 埠E0/1屬於vlan10,E0/2屬於vlan20,E0/3與SwitchA埠E0/3互連x0dx0a【組網需求】x0dx0a1. 要求SwitchA的vlan10的PC與SwitchB的vlan10的PC互通x0dx0a2. 要求SwitchA的vlan20的PC與SwitchB的vlan20的PC互通x0dx0a【SwitchA相關配置】x0dx0a1. 創建(進入)VLAN10,將E0/1加入到VLAN10x0dx0a[SwitchA]vlan 10x0dx0a[SwitchA-vlan10]port Ethernet 0/1x0dx0a2. 創建(進入)VLAN20,將E0/2加入到VLAN20x0dx0a[SwitchA]vlan 20x0dx0a[SwitchA-vlan20]port Ethernet 0/2x0dx0a3. 配置埠e0/3 trunk埠,實際當中一般將上行埠設置成trunk屬性x0dx0a[SwitchA-Ethernet0/3]port link-type trunkx0dx0a4.允許所有vlan通過,x0dx0a[SwitchA-Ethernet0/3]port trunk permit vlan allx0dx0a5.一般情況下最好指定埠允許通過哪些具體的VLAN,不要設置允許所有的VLAN通過x0dx0a例如:[SwitchA-Ethernet0/3]port hybrid vlan 10 20 untaggedx0dx0a【SwitchB相關配置】x0dx0a1. 創建(進入)VLAN10,將E0/1加入到VLAN10x0dx0a[SwitchB]vlan 10x0dx0a[SwitchB-vlan10]port Ethernet 0/1x0dx0a2. 創建(進入)VLAN20,將E0/2加入到VLAN20x0dx0a[SwitchB]vlan 20x0dx0a[SwitchB-vlan20]port Ethernet 0/2x0dx0a3. 配置埠e0/3 trunk埠,實際當中一般將上行埠設置成trunk屬性x0dx0a[SwitchB-Ethernet0/3]port link-type trunkx0dx0a4.允許所有vlan通過,x0dx0a[SwitchB-Ethernet0/3]port trunk permit vlan allx0dx0a5.一般情況下最好指定埠允許通過哪些具體的VLAN,不要設置允許所有的VLAN通過x0dx0a例如:[SwitchB-Ethernet0/3]port hybrid vlan 10 20 untaggedx0dx0ax0dx0a23,24系列的交換機可能稍微有點出入,有出入的地方進了介面打問號,

㈡ cisco二層交換機和三層交換機怎麼設置trunk

trunk的配置方法在二層交換機和三層交換機的配置方法都是一樣的。
en
conf
t
int
f0/24
(埠號自己定,我這個就是個例子)
Switchport
mode
trunk
(指定埠類型為trunk,如果不行就是先設置為access,然後在設置為trunk)
switchport
trunk
encapsulation
dot1q
(指定trunk封裝協議為dot1q)
switchport
trunk
allowed
vlan
10,20
(思科trunk默認允許所有vlan通過,可以使用改名了設置允許通過trunk的vlan)
步驟和命令都一樣,注意要做trunk鏈路兩端的埠都要配置。

㈢ 交換機里的TRUNK是幹嘛用的怎麼去配置

Trunk功能用於交換機與伺服器之間的相聯,為伺服器提供獨享的高帶寬。

Trunk功能用於交換機之間的級聯,為交換機之間的數據交換提供高帶寬的數據傳輸能力,提高網路速度,突破網路瓶頸,進而大幅提高網路性能(主要應用)。

具體配置如下:

1、首先看一下拓撲圖,我們可以看到兩台交換機之間需要配置trunk才能實現不同交換機下的同一個vlan互相訪問

㈣ cisco二層交換機和三層交換機怎麼設置trunk

cisco二層交換機設置trunk:

S1>enable //進入特權模式

S1#config terminal //進入全局配置模式

S1(config)# interface vlan [vlanID] //進入vlan埠

S1(config-if)#switchport mode trunk //埠設置為trunk模式

三層交換機設置trunk:

S1>enable //進入特權模式

S1#config terminal //進入全局配置模式

S1(config)# interface vlan [vlanID] //進入vlan埠

S1(config-if)#switchport trunk encapsulation dot1q //封裝協議

S1(config-if)#Switchport mode trunk //埠設置為trunk模式

(4)2k交換機怎麼配置trunk擴展閱讀

交換機常見命令:

S1(config-if)#switchport trunk native vlan [vlanID] //設置為本徵vlan

S1(config-if)#switchport trunk allowed vlan word/add/all/except/none/remove

//運行哪些vlan在本徵vlan通信

S1(config-if)# do show interface trunk //查看埠trunk

S1#Show interface trunk //查看中繼介面狀態

S1#Show vlan brief //查看VLAN摘要信息

㈤ 交換機的trunk介面怎麼配置

不同的交換機配置命令各不相同,這里只提供一個思路:
首先,將介面配置為trunk口:swithport mode trunk,這個命令是思科的,別的廠商的命令所用的字眼不會是這樣的,但意思差不多。
接著,選擇一種trunk封裝協議,比如:swithport trunk encapsulation dot1q

㈥ huawei 的交換機如何配置trunk

舉個例子:
interface GigabitEthernet1/1/1 //物理介面
port link-type trunk
port trunk permit vlan 11,12 //所允許的VLAN

㈦ Cisco交換機Trunk配置命令!

1.(config)#int
f0/0
//進入相應介面,如果是多個介面可以使用命令
int
range
f0/
0
-
n
2.(config-if)#switchport
trunk
encapsulation
{dot1q|isl
}//封裝dot1q或者isl(isl為思科私有,dot1q是802.1q,通用)
3.(config-if)#switchport
mode
trunk
//配置埠為trunk類型
4.(config-if)#switchport
trunk
allowed
vlan
all
//trunk允許所有vlan的流量通過
注意:2和3順序不可顛倒

㈧ 交換機兩埠連線怎樣設置為trunk模式

enable
conf t
int f0/1
switchport mode trunk

另一台設置相同,思科設備也可以使用cisco的私有協議DTP自動協商成為TRUNK口

㈨ 思科交換機配置TRUNK的主要步驟

思科交換機配置TRUNK的主要步驟

到底什麼是TRUNK呢?使用TRUNK功能到底能給我們帶來哪些應用方面的優勢?還有在具體的交換機產品中怎樣來進行交換機配置TRUNK,下面我們來了解一下這些方面的知識。

在二層交換機的性能參數中,常常提到一個重要的指標:TRUNK,許多的二層交換機產品在介紹其性能時,都會提到能夠支持TRUNK功能,從而可以為互連的交換機之間提供更好的傳輸性能。那到底什麼是TRUNK呢?使用TRUNK功能到底能給我們帶來哪些應用方面的優勢?還有在具體的交換機產品中怎樣來進行交換機配置TRUNK。下面我們來了解一下這些方面的知識。

一、什麼是TRUNK?

TRUNK是埠匯聚的意思,就是通過配置軟體的設置,將2個或多個物理埠組合在一起成為一條邏輯的路徑從而增加在交換機和網路節點之間的帶寬,將屬於這幾個埠的帶寬合並,給埠提供一個幾倍於獨立埠的獨享的高帶寬。Trunk是一種封裝技術,它是一條點到點的鏈路,鏈路的兩端可以都是交換機,也可以是交換機和路由器,還可以是主機和交換機或路由器。基於埠匯聚(Trunk)功能,允許交換機與交換機、交換機與路由器、主機與交換機或路由器之間通過兩個或多個埠並行連接同時傳輸以提供更高帶寬、更大吞吐量, 大幅度提供整個網路能力。

一般情況下,在沒有使用TRUNK時,大家都知道,百兆乙太網的雙絞線的這種傳輸介質特性決定在兩個互連的普通10/100交換機的帶寬僅為100M,如果是採用的全雙工模式的話,則傳輸的最大帶寬可以達到最大200M,這樣就形成了網路主幹和伺服器瓶頸。要達到更高的數據傳輸率,則需要更換傳輸媒介,使用千兆光纖或升級成為千兆乙太網,這樣雖能在帶寬上能夠達到千兆,但成本卻非常昂貴(可能連交換機也需要一塊換掉),更本不適合低成本的中小企業和學校使用。如果使用TRUNK技術,把四個埠通過捆綁在一起來達到800M帶寬,這樣可較好的解決了成本和性能的矛盾。

二、TRUNK的具體應用

TRUNK(埠匯聚)是在交換機和網路設備之間比較經濟的增加帶寬的方法,如伺服器、路由器、工作站或其他交換機。這中增加帶寬的方法在當單一交換機和節點之間連接不能滿足負荷時是比較有效的。

TRUNK 的主要功能就是將多個物理埠(一般為2-8個)綁定為一個邏輯的通道,使其工作起來就像一個通道一樣。將多個物理鏈路捆綁在一起後,不但提升了整個網路的帶寬,而且數據還可以同時經由被綁定的多個物理鏈路傳輸,具有鏈路冗餘的作用,在網路出現故障或其他原因斷開其中一條或多條鏈路時,剩下的鏈路還可以工作。但在VLAN數據傳輸中,各個廠家使用不同的技術,例如:思科的產品是使用其VLAN TRUNK 技術,其他廠商的產品大多支持802.1q協議打上TAG頭,這樣就生成了小巨人幀,需要相同埠協議的`來識別,小巨人幀由於大小超過了標准以太幀的1518位元組限制,普通網卡無法識別,需要有交換機脫TAG。TRUNK功能比較適合於以下方面具體應用:

1、TRUNK功能用於與伺服器相聯,給伺服器提供獨享的高帶寬。

2、TRUNK功能用於交換機之間的級聯,通過犧牲埠數來給交換機之間的數據交換提供捆綁的高帶寬,提高網路速度,突破網路瓶頸,進而大幅提高網路性能。

3、Trunk可以提供負載均衡能力以及系統容錯。由於Trunk實時平衡各個交換機埠和伺服器介面的流量,一旦某個埠出現故障,它會自動把故障埠從Trunk組中撤消,進而重新分配各個Trunk埠的流量,從而實現系統容錯。

三、如何設置TRUNK?

設置TRUNK需要指定一個作為主幹的埠,比如2/24,如把某個埠設成Trunk方式,命令如下:set trunk mod/port [on | off | desirable | auto | nonegotiate] [vlan_range] [isl | dot1q dot10 | lane | negotiate]。該命令可以分成以下4個部分:mod/port:指定用戶想要運行Trunk的那個埠;Trunk的運行模式,分別有:on | off | desirable | auto | nonegotiate。

要想在快速乙太網和千兆乙太網上自動識別出Trunk,則必須保證在同一個VTP域內。也可以使用On或Nonegotiate模式來強迫一個埠上起Trunk,無論其是否在同一個VTP域內。承載的VLAN范圍。預設下是1~1005,可以修改,但必須有TRUNK協議。使用TRUNK時,相鄰埠上的協議要一致。另外在中心交換機上需要把和下面的交換機相連的埠設置成TRUNK,這樣下面的交換機中的多個VLAN就能夠通過一條鏈路和中心交換機通信了。

四、交換機配置TRUNK時的注意事項

在一個TRUNK中,數據總是從一個特定的源點到目的點,一條單一的鏈路被設計去處理廣播包或不知目的地的包。在交換機配置TRUNK時,必須遵循下列規則:

1:正確選擇TRUNK的埠數目,必須是2,4或8。

2:必須使用同一組中的埠,在交換機上的埠分成了幾個組,TRUNK的所有埠必須來自同一組。

3:使用連續的埠;TRUNK上的埠必須連續,如你可以用埠4,5,6和7組合成一個埠匯聚。

4:在一組埠只產生一個TRUNK。

拓展:如何初始化思科路由器和交換機的密碼

一、路由器密碼恢復

按照以下步驟恢復路由器密碼:

1、關閉路由器的電源並在10秒後重新給路由器加電,在給路由器加電的同時(也可在路由器重啟的60秒內)按住鍵盤上的Ctrl+Break幾秒鍾,待出現路由器提示符rommon 1 >後,輸入confreg 0x2142或為 o/r 0x2142命令修改配置寄存器的值,其中的4表示跳過啟動配置文件startup-config。

2、輸入reset命令重新啟動路由器。

3、當路由器重新啟動結束出現提示是否運行配置向導時,輸入「n」回到路由器提示符。

4、輸入enable命令進入特權用戶模式。

5、輸入 startup-config running-config命令將啟動配置文件拷貝到運行配置文件中。

6、輸入configure terminal命令進入全局配置模式。

7、輸入enable secret newpass命令重新設置加密使能密碼(當然如果需要,也可以在此更改使能密碼及虛擬終端密碼)。

8、輸入exit命令回到全局配置模式。

9、輸入config-register 0x2102命令將配置寄存器的值恢復成預設值。

10、輸入exit命令回到特權用戶模式。

11、輸入 running-config startup-config命令將運行配置文件保存到啟動配置文件中。

12、輸入reload命令重啟啟動路由器。到此為止,密碼恢復過程完成。

13、待路由器啟動結束後,輸入若干此「回車」直到出現路由器提示符Router>。

14、輸入enable命令進入特權用戶模式,在被提示輸入密碼時輸入新設置的加密使能密碼,檢查剛才的密碼恢復過程是否正確執行。

二、交換機密碼恢復

按照以下步驟恢復路由器密碼:

1、斷開交換機的電源並重新給交換機加電,在給交換機加電的同時按住交換機前面板上的「模式(Mode)」按鈕幾秒鍾,仔細觀察超級終端程序中顯示的交換機啟動信息。

2、待出現交換機提示符switch:後,輸入flash_init命令。

3、待上述命令執行完成後,輸入load_helper命令。

4、待上述命令執行完成後,輸入dir flash: 命令查看快閃記憶體中的文件列表。

5、輸入rename flash:config.text flash:config.back命令將快閃記憶體中的保存有密碼的文件改名。

6、輸入reset命令重新啟動交換機(也可輸入boot命令繼續交換機啟動進程)。

7、當交換機重新啟動結束出現提示是否運行配置向導時,輸入「n」回到交換機提示符。

8、輸入enable命令進入特權用戶模式。

9、輸入命令rename flash:config.back flash:config.text。

10、輸入 flash:config.text system:running-config命令並確認。

11、輸入configure terminal命令進入全局配置模式。

12、輸入enable secret newpass命令重新設置加密使能密碼(如果需要也可以在此更改使能密碼及虛擬終端密碼)。

13、輸入end命令回到特權用戶模式。

14、輸入 running-config startup-config命令將運行配置文件保存到啟動配置文件中。到此為止,密碼恢復過程完成。

15、輸入disable命令退到普通用戶模式。

16、輸入enable命令進入特權用戶模式,在被提示輸入密碼時輸入新設置的加密使能密碼,檢查剛才的密碼恢復過程是否正確執行。

;
熱點內容
零基礎學php難嗎 發布:2023-02-05 14:49:49 瀏覽:540
仿qq聊天界面android 發布:2023-02-05 14:47:46 瀏覽:247
創建域用戶的ftp訪問目錄 發布:2023-02-05 14:46:58 瀏覽:890
安卓手機錄屏在哪裡設置的 發布:2023-02-05 14:46:53 瀏覽:673
樹莓派4b搭建mqtt伺服器 發布:2023-02-05 14:43:13 瀏覽:860
win2008ftp伺服器 發布:2023-02-05 14:32:00 瀏覽:127
elink配置同步有什麼好處 發布:2023-02-05 14:25:39 瀏覽:682
sqlserver不能安裝 發布:2023-02-05 14:22:39 瀏覽:211
三星手機如何刷機解鎖密碼 發布:2023-02-05 14:20:25 瀏覽:900
iapp社區源碼 發布:2023-02-05 14:20:24 瀏覽:758