當前位置:首頁 » 存儲配置 » 易語言怎麼生成配置文件

易語言怎麼生成配置文件

發布時間: 2023-03-24 09:55:31

Ⅰ 易語言寫配置項和讀配置項的具體做法是什麼

文件名稱update.ini

測試內容

[1]
1-1=V1-1
1-2=V1-2
1-3=V1-3
1-4=V1-4
1-5=V1-5
1-6=V1-6
[2]
2-1=V2-1
2-2=V2-2
2-3=V2-3
2-4=V2-4
2-5=V2-5
2-6=V2-6

測試代碼

.版本2
.支持庫spec

.局部變數配置文件名,文本型
.局部變數節計數器1,整數型
.局部變數配置項計數器1,整數型

配置文件名=取運行目錄()+「serverupdate.ini」
.變數循環首(1,2,1,節計數器1)
.變數循環首(1,6,1,配置項計數器1)
調試輸出(讀配置項(配置文件名,到文本(節計數器1),到文本(節計數器1)+「-」+到文本(配置項計數器1),「」))
.變數循環尾()
.變數循環尾()

既然能輸出來所有的數據,怎麼利用這個更新文件其實很簡單

1-文件更新肯定要先知道伺服器上的配置文件目錄和文件,這個直接寫在程序路徑就OK

2-獲取要更新文件的數量,格磨槐扒式嘛,就按照我這里大概的思路了,節名稱[1]代表第一個文件,以瞎昌此類推

獲取1-1這個可以存儲需要更新的列表文件名稱1-2可以存儲配置項名稱1-3存儲配置項對應的val值

用於本地INI的配置高還原和靈活性

本地的ini被整理出來的格式

文件名稱:V1-1->update.ini

V1-2->[節名稱1]

V1-3->配置項名稱

V1-4->配置項值

這個方法自己總結的,效果還不錯,應對大批量,要使用同一個文件名稱不同更新的問題,這個就明悉很好解決的方案

Ⅱ 易語言怎麼調用config配置文件

config.ini 內容如下:


[配亮談置項目]

時間=136

易語言讀取代碼如下:櫻皮

設定脊鍵差的時間=讀配置項(取現行目錄()+"/config.ini","配置項目","時間")

Ⅲ 易語言寫配置項

按照你說的邏輯,兩層的條件嵌套就可以實現

1、判斷setup.ini文件是否存在,存在進入第二步判斷,不存在則創建setup.ini寫入兩個0

2、判斷setup.ini文件是記住賬號和記住密碼兩項是否為1,是的話編輯框自動填寫內容,否的話編輯框內容空



下面這個代碼對應的窗口控制項,一個按鈕,兩個編輯框

Ⅳ 易語言想寫一個配置文件到桌面的文件夾下,文件名叫我的配置項,應該怎麼寫

寫備源到文件 (取特定目錄 (3) +羨滾棚 「兄則我的文件\我的配置項.ini」, 到位元組集 ("要寫的內容"))

Ⅳ 如何用易語言寫組合框內容的配置文件

每輸一次號碼,你就把號碼和對應的序號寫到配置文件里,然後重新運行軟體的時候再用一個計次循環把配置文件讀到組合框的記錄裡面,總體思路是這樣,配置文件你自己編格式就行了,要費點功夫。慢慢來。
我以前寫的一個:
這是寫配置
.版本
2
.如果
(P
=
「」)
寫到文件
(取運行目錄
()
+
「悶襪/QQ.dll」,
到位元組集
(組合框QQ賬號.內容咐罩畝))
載入
(窗口1,
,
假)
.否則
寫到文件
(取運行目錄
()
+
「/QQ.dll」,
到位元組集
(P
+
#換行符
+
組合框QQ賬號.內容))
載入
(窗口1,
,
假)
這是讀配置
.版本
2
.子程序
讀取記憶
.局部變數
文本,
文本型
.局部變數
分割,
文本型,
,
"0"
.局部變數
L,
整數型
文本
=
到文本
(讀入文件
(取運行目錄
()
+
「/QQ.dll」))
分割
=
分割文本
(文本,
#換行符,
)
組合框QQ賬號.清空
()
.計次循環首
(取數組成員數
(分割),
L)
組衡森合框QQ賬號.加入項目
(分割
[L],
)
.計次循環尾
()
為了回答你這個問題我找了好久,以前的東西都不知道跑去哪裡了。

Ⅵ 易語言怎麼寫ini配置

嗯,你先了解2個代碼1.寫配置項2.讀配置項寫配置項(配置文件名型搜,節名稱,配置項名稱,欲寫入值)讀配置項(配置文件嗎,節名稱,配置項名稱,默認文本)
具體思路:首先設定2個程序集變數。1.是否記住帳號2.是否記住密碼
然後:寫配置項(取運行目錄
()

「\」

到文本
(「配置」)

「.ini」,「Config」,「記住帳號」,是否記住帳號)寫配置項(取運行目錄
()

「\」

到文本
(「配置」)

「.ini」,「Config」,「記住密碼」,是否記住密碼)
思路:每次程序啟動,用一個條件來讀配置項,如果真,那麼
編輯框1.內容
=
到數值
(讀配置項
(取運行目錄
()

「\」

到文並租蘆本
(「配置」)

「.ini」,
「config」,
「記住絕帶帳號」,
))
密碼也以此類推,根據樓主不同的需要來寫不同的條件判斷。

Ⅶ 易語言寫配置項和讀配置項的具體做法是什麼

.版本 2
.子程序 讀用戶配置
' 配置文件名, "「\USERSYS.ini」", , 用戶配置文件
' 系統風格節, "「系統風格」", , 系統配置XP風格
' 風格, "「XP風格」", , 界面使用XP風格樣式
' 窗口位置左, "「左邊」"
' 窗口位置頂, "「頂邊」"
' 窗口寬, "「寬度」"
' 窗口高, "「高度」"
' 用老銷戶配色節, "「自定義顏色」", , 用戶自定義的配置
' 窗口色項, "「窗口背景」"
' 編輯框底色, "「文字背景」"
' 文字色項, "「文字顏色」"
' 文字大小, "「字型大小」"
' 文字字體, "「字體」"
' 用戶信息節, "「用戶信息」", , 用戶的信息
' 名項, "「用戶名」"
' 址項, "「用戶公司」"
' 最近文件節, "「最近打開」", , 使用的文件
' 上次文件, "「上次打開」"
' 自動打開, "「自動打開」"
上次文件.標題 = 「」
.如果 (讀配置項 (配置路徑, #最近文件節, #自動打開, ) = 「YES」)
自動打開.選中 = 真
.如果真 (文件是否存在 (讀配置項 (配置路徑, #最近文件節, #上次文件, )))
上次文件.標題 = 讀配置項 (配置路徑, #最近文件節, #上次文件, )
上次文件.可視 = 上次文件.標題 ≠ 「」
_上次文件_被選擇 ()
.如果真結束
.否則
自動打開.選中 = 假
上次文件.可視 = 假
.如果結束
.如果 (讀配置項 (配置路徑, #系統風格節, #最大化, ) ≠ 「YES」)
_啟動窗口.移動 (到數值 (讀配置項 (配置路徑, #系統風格節, #窗口位置左, )), 到數值 (讀配置項 (配置路徑, #系統風格節, #窗口位置頂, )), 到數值 (讀配置項 (配置路徑, #系統風格節, #窗口寬, 「400」)), 到數值 (讀配置項 (配置路徑, #系統風格節, #窗口高, 「300」)))
.否則
_啟動窗口.位置 = 3
.如果結束
總是最前.選中 = 讀配置項 (配置路徑, #系統風格節, #總在最前, ) = 「1」
_啟動窗口.總在最前 = 總是最前.選中
編輯框1.字體.字體大小 = 到數值 (讀配置項 (配置路徑, #用戶配色梁頃節, #文字大小, 「9」))
編輯框1.字體.字體名稱 = 讀配置項 (配置路徑, #用戶配色節橡含陸, #文字字體, 「宋體」)
讀配色 ()
讀用戶 ()
讀風格 ()

.版本 2
.子程序 讀配色
_啟動窗口.底色 = 到數值 (讀配置項 (配置路徑, #用戶配色節, #窗口色項, 到文本 (#默認色)))
編輯框1.背景顏色 = 到數值 (讀配置項 (配置路徑, #用戶配色節, #編輯框底色, 到文本 (#白色)))
編輯框1.文本顏色 = 到數值 (讀配置項 (配置路徑, #用戶配色節, #文字色項, 到文本 (#黑色)))

.版本 2
.支持庫 xplib
.子程序 讀風格
.局部變數 KK, 整數型
連續賦值 (假, 無風格.禁止, 藍色風格.禁止, 綠色風格.禁止, 銀色風格.禁止)
KK = 到數值 (讀配置項 (配置路徑, #系統風格節, #風格, 「0」))
XP風格 (KK)
.判斷開始 (KK = 0)
無風格.禁止 = 真
.判斷 (KK = 1)
藍色風格.禁止 = 真
.判斷 (KK = 2)
綠色風格.禁止 = 真
.判斷 (KK = 3)
銀色風格.禁止 = 真
.默認
.判斷結束

.版本 2
.子程序 讀用戶
_啟動窗口.標題 = 讀配置項 (配置路徑, #用戶信息節, #名項, 「大強」) + 「記事本」

.版本 2
.子程序 __啟動窗口_尺寸被改變
.如果真 (_啟動窗口.寬度 ≤ 200)

_啟動窗口.寬度 = 200
.如果真結束
.如果真 (_啟動窗口.高度 ≤ 300)
_啟動窗口.高度 = 300
.如果真結束
.如果真 (_啟動窗口.位置 ≠ 3)
寫配置項 (配置路徑, #系統風格節, #窗口位置左, 到文本 (_啟動窗口.左邊))
寫配置項 (配置路徑, #系統風格節, #窗口位置頂, 到文本 (_啟動窗口.頂邊))
寫配置項 (配置路徑, #系統風格節, #窗口寬, 到文本 (_啟動窗口.寬度))
寫配置項 (配置路徑, #系統風格節, #窗口高, 到文本 (_啟動窗口.高度))
_啟動窗口.移動 (到數值 (讀配置項 (配置路徑, #系統風格節, #窗口位置左, )), 到數值 (讀配置項 (配置路徑, #系統風格節, #窗口位置頂, )), 到數值 (讀配置項 (配置路徑, #系統風格節, #窗口寬, 「400」)), 到數值 (讀配置項 (配置路徑, #系統風格節, #窗口高, 「300」)))
.如果真結束
編輯框1.移動 (5, 5, _啟動窗口.取用戶區寬度 () - 10, _啟動窗口.取用戶區高度 () - 10)

這是我的程序中的代碼,你也可以到易語言資源網去下載這個程序的源碼

Ⅷ 易語言怎樣寫出指定的ini配置文件

寫配置項 (取運行目錄 () +「\serverlist.ini」, 「消滾卜ServerCount」, 「count」, 「1」備閉) 這是第一個節名稱[ServerCount]的配置拿穗寫法,下面的類推。

Ⅸ 易語言怎麼寫列表框的配置項

  • 打開「易語言主程序」,進入「新建易語言工程文件」對話框,果斷選擇第一個「Windows窗口程序」然後點擊「確定」按鈕,進入易語言窗口程序設計界面。

Ⅹ 用易語言如何生成配置文件.ini

寫配置(,,)
讀配置(,,)
這些都殲拆局是易系統自帶的。
這里才是真正配置寫法。

寫到文件(取特定目錄(3) 「配置.ini」,{ })
這樣也能在指定位置御渣寫出個配置.ini
但是後者,只是寫個氏讓空文件。

熱點內容
創造與魔法ios腳本刷龍涎草 發布:2024-05-22 12:44:22 瀏覽:524
如何從安卓導數據到蘋果 發布:2024-05-22 12:15:59 瀏覽:274
博越互聯版屬於什麼配置 發布:2024-05-22 12:11:46 瀏覽:224
伺服器除了dns還有什麼 發布:2024-05-22 11:58:14 瀏覽:291
android開發背景 發布:2024-05-22 11:54:01 瀏覽:181
java文件怎麼保存 發布:2024-05-22 11:17:17 瀏覽:828
安卓系統是哪裡造的 發布:2024-05-22 11:11:23 瀏覽:474
linux下sh 發布:2024-05-22 11:10:16 瀏覽:310
勞動資源配置中的自然配置是什麼 發布:2024-05-22 10:54:53 瀏覽:676
asp的資料庫 發布:2024-05-22 10:29:05 瀏覽:139