當前位置:首頁 » 編程軟體 » 易語言程序編譯打亂

易語言程序編譯打亂

發布時間: 2022-08-06 07:17:46

⑴ 易語言多行文本亂序

.版本 2


.子程序 _按鈕1_被單擊

.局部變數 i, 整數型

.局部變數 str, 文本型, , "0"

.局部變數 n, 整數型

.局部變數 temp, 文本型

.局部變數 r, 整數型


編輯框2.內容 = 「」

str = 分割文本 (編輯框1.內容, #換行符, )

置隨機數種子 ()

n = 取數組下標 (str, )

.計次循環首 (n, i)

r = 取隨機數 (1, n)

temp = str [i]

str [i] = str [r]

str [r] = temp

.計次循環尾 ()

.計次循環首 (n, i)

編輯框2.加入文本 (str [i] + #換行符)

.計次循環尾 ()

⑵ 為什麼易語言程序會有毒

可能是有某些病毒木馬類似的功能,如果都報毒,可能是設置了「編譯結果打亂」。工具→編譯配置,保護,把編譯結果打亂設置成0就沒事。

⑶ 易語言打亂次序

數組亂序?

.版本 2

.支持庫 spec


.局部變數 array, 整數型, , "0"

.局部變數 _array, 整數型, , "0"

.局部變數 i, 整數型


array = { 1, 2, 3, 4, 5 }

.判斷循環首 (取數組成員數 (array) > 0)

i = 取隨機數 (1, 取數組成員數 (array))

加入成員 (_array, array [i])

刪除成員 (array, i, )

.判斷循環尾 ()

調試輸出 (_array)

⑷ 易語言怎樣隨機打亂數字

您好,我想我應該可以解答您的問題
用命令:
按鈕1被單擊
編輯框1.內容=到文本(取隨機數(1,4))
編輯框2.內容=到文本(取隨機數(1,4))
編輯框3.內容=到文本(取隨機數(1,4))
編輯框4.內容=到文本(取隨機數(1,4))
再如果,如果,如果,如果
這樣應該就可以了
這只是一個我的思路

⑸ 易語言 如何將編譯打亂

誤報的話,你可以嘗試完全不加殼不加花..加花反而報的多
現在其實很少遇到誤報了..
另外去論壇下個修改支持庫的那個工具改改試試,據說有用

⑹ 易語言怎樣隨機打亂字元

多種方法可以實現

1、把這62個字元放在一個數組中,然後隨機取出兩個數組成員,把它們的內容進行交換,如此重復100次或更多,就得到一個隨機的字元串數組了

2、和前面一樣,做成一個數組,然後隨機從其中取一個字元放在另一個數組中,並把原數組中的此成員刪除,然後再隨機取一個,重復多次,新數組就是一個隨機字元數組了,注意:原數組每刪除一個成員,取隨機數時的上限要遞減一。

推薦使用第一種方法。

⑺ 易語言 打亂文本(註:高手來)

數組_排列()只是針對不同類型的參考使用
傻子數組隨機排序()適用於文本數組

.子程序 傻子數組隨機排序, 整數型, , 取出一個數組隨機排列的結果至新變數組,返回數組數
.參數 傻子文本, 文本型, 數組
.參數 返回傻子隨機組, 文本型, 數組
.參數 數組隨機排列的結果, , 參考 可空 數組
.局部變數 傻子次數
.局部變數 數組, 整數型, , "0"
.局部變數 數組次數, 整數型
.局部變數 A, 整數型
.局部變數 B, 整數型
.局部變數 臨時, 整數型

清除數組 (返回傻子隨機組)
' 傻子文本 = { 「我」, 「愛」, 「傻」, 「子」 }
傻子次數 = 取數組成員數 (傻子文本)
.計次循環首 (傻子次數, 數組次數)
加入成員 (數組, 數組次數)
.計次循環尾 ()
置隨機數種子 (取啟動時間 ())
.計次循環首 (傻子次數 + 1, 數組次數)
A = 取隨機數 (1, 傻子次數)
B = 取隨機數 (1, 傻子次數)
臨時 = 數組 [A]
數組 [A] = 數組 [B]
數組 [B] = 臨時
.計次循環尾 ()
.計次循環首 (傻子次數, 數組次數)
加入成員 (數組隨機排列的結果, 數組 [數組次數])
加入成員 (返回傻子隨機組, 傻子文本 [數組 [數組次數]])
.計次循環尾 ()

返回 (數組次數)

.版本 2

.子程序 數組_排列, , , 文本數組必須與排列數序的數組一致
.參數 文本型數組, 文本型, 數組
.參數 排列順序, , 數組, 按照整數型數組里的成員數據進行排列
.參數 返回值, 文本型, 參考 數組
.局部變數 i, 整數型

清除數組 (返回值)
.如果真 (取數組成員數 (文本型數組) ≠ 取數組成員數 (排列順序))
返回 ()
.如果真結束

.計次循環首 (取數組成員數 (文本型數組), i)
加入成員 (返回值, 文本型數組 [排列順序 [i]])
.計次循環尾 ()

⑻ 易語言怎樣點擊按鈕將列表框中項的順序打亂急急急!

.版本 2

.支持庫 spec

.子程序 _按鈕1_被單擊

.局部變數 列表數據, 文本型, , "0"

.局部變數 置入位置, 整數型

.局部變數 耗時, 整數型

.局部變數 i, 整數型

耗時 = 取啟動時間 ()

.計次循環首 (列表框1.取項目數 (), i)

加入成員 (列表數據, 列表框1.取項目文本 (i - 1))

.計次循環尾 ()

列表框1.清空 ()

.判斷循環首 (取數組成員數 (列表數據) > 1)

置入位置 = 取隨機數 (1, 取數組成員數 (列表數據))

列表框1.加入項目 (列表數據 [置入位置], )

.如果真 (列表數據 [置入位置] = 「」)

調試輸出 (列表數據, 置入位置)

.如果真結束

刪除成員 (列表數據, 置入位置, 1)

.判斷循環尾 ()

列表框1.加入項目 (列表數據 [1], )

調試輸出 (取啟動時間 () - 耗時)

⑼ 易語言寫的程序360都要報毒怎麼辦

易語言寫的程序360都要報毒,可以到360軟體開放平台的易語言軟體開發者誤報反饋頁面進行反饋。

熱點內容
科沃茲哪個配置最耐用 發布:2022-08-10 23:10:36 瀏覽:525
高級編程第6版 發布:2022-08-10 23:08:47 瀏覽:607
au錄音需要什麼配置筆記本 發布:2022-08-10 23:03:07 瀏覽:380
維普資料庫檢索途徑 發布:2022-08-10 23:03:01 瀏覽:400
傳奇外傳掛機腳本免費 發布:2022-08-10 23:01:33 瀏覽:488
緩存器和程序存儲器 發布:2022-08-10 22:59:57 瀏覽:291
i社游戲解壓碼 發布:2022-08-10 22:58:31 瀏覽:219
cygwin編譯器 發布:2022-08-10 22:57:03 瀏覽:756
modpython 發布:2022-08-10 22:55:46 瀏覽:735
雲伺服器圖形界面 發布:2022-08-10 22:54:06 瀏覽:145