當前位置:首頁 » 操作系統 » 易語言演算法

易語言演算法

發布時間: 2022-01-08 19:27:21

Ⅰ 易語言畫線演算法

易語言畫線演算法:用滑鼠穿透。

四個畫板作為1234象限,然後自己定義個X,Y變數,取一個范圍內的X,Y值畫點。最後用畫線連點,個人推薦畫板寬度300,4個畫板就是600的大小,只取函數在-3,3的位置的點,這樣就能畫出小數點後兩位的點。

支持庫:

易語言支持庫實際上是DLL文件。通過使用其它編程語言為易語言開發支持庫,易語言系統的功能可以得到無限擴展。

這種支持庫是易語言專用的,其它編程語言也可以使用,但需要經過復雜的調用。支持庫文件擴展名有fne、fnr、fnl、npk四種。fne製作好的DLL文件,例如系統核心支持庫、應用介面支持庫。該類支持庫一般由用戶使用C++或Delphi製作,具體可以看易語言支持庫開發手冊。




Ⅱ 在易語言中計算公式

計算式很簡單,你想讓人幫你全部寫,啥分都沒有,懶得寫。
保留小數點後兩位就用
四捨五入 (, ) 這個命令就好了
其他的 計算都很簡單,自己寫吧

Ⅲ 易語言時鍾周期演算法

.版本 2
.支持庫 spec

.程序集變數 h, 整數型
.程序集變數 g, 整數型

.子程序 __啟動窗口_創建完畢

h = 255
g = 0 ' 設h=255,g=0
時鍾1.時鍾周期 = 100 ' 在時鍾周期內

.子程序 _時鍾1_周期事件

h = h - 10 ' ' h每十分之一秒減10
.如果真 (h ≤ 255)
調試輸出 (「h = 」 + 到文本 (h)) ' 如果h≤255,則顯示h
.如果真結束

.如果真 (h ≤ 0) ' 如果h≤0,則g每十分之一秒加10,顯示g
g = g + 10
調試輸出 (「g = 」 + 到文本 (g))
.如果真結束

.如果真 (g ≥ 255) ' 如果g≥255,則h每十分之一秒減10,顯示h
h = h - 10
調試輸出 (「g ≥ 255 h = 」 + 到文本 (h))
.如果真結束

Ⅳ 易語言求演算法: 題目如下:

.版本2

.子程序_按鈕1_被單擊

.局部變數市場部人員數組,文本型,,"0"

.局部變數網路部人員數組,文本型,,"0"

.局部變數市場部人數,整數型

.局部變數網路部人數,整數型

.局部變數tmp,整數型

.局部變數循環變數,整數型

市場部人數=載入名單(「市場部人員名單.txt」,市場部人員數組)

網路部人數=載入名單(「網路部人員名單.txt」,網路部人員數組)

.如果真(網路部人數<市場部人數)

返回()

.如果真結束

tmp=0

.計次循環首(網路部人數,循環變數)

tmp=tmp+1

.如果真(tmp>市場部人數)

tmp=1

.如果真結束

市場部人員數組[tmp]=市場部人員數組[tmp]+「,」+網路部人員數組[循環變數]

處理事件()

.計次循環尾()

保存名單(「配對表.csv」,市場部人員數組)

結束()

.子程序載入名單,整數型

.參數文件名,文本型

.參數文本數組,文本型,參考數組

.局部變數文件號,整數型

.局部變數臨時文本,文本型

文件號=打開文件(文件名,1,3)

移到文件首(文件號)

.判斷循環首(取反(是否在文件尾(文件號,)))

臨時文本=讀入一行(文件號)

.如果真(取文本長度(臨時文本)>0)

加入成員(文本數組,臨時文本)

.如果真結束

處理事件()

.判斷循環尾()

關閉文件(文件號)

返回(取數組下標(文本數組,))

.子程序保存名單

.參數文件名,文本型

.參數文本數組,文本型,參考數組

.局部變數文件號,整數型

.局部變數cnt,整數型

.局部變數tmp,整數型

文件號=打開文件(文件名,4,4)

移到文件首(文件號)

寫文本行(文件號,「市場部,網路部」)

cnt=取數組下標(文本數組,)

.計次循環首(cnt,tmp)

寫文本行(文件號,文本數組[tmp])

處理事件()

.計次循環尾()

關閉文件(文件號)

Ⅳ 易語言 計算概率問題

Ⅵ 易語言 數組排列演算法

.版本 2
.程序集 窗口程序集_啟動窗口
.子程序 _按鈕1_被單擊
.局部變數 a, 整數型, , "5"
a = { 1, 2, 3, 4, 5 }
排列 (a, 3)
.子程序 排列
.參數 a, 整數型, 數組
.參數 n, 整數型
.局部變數 i, 整數型
.局部變數 j, 整數型
.局部變數 k, 整數型
.局部變數 臨時文本, 文本型
.計次循環首 (到整數 (求次方 (2, 取數組成員數 (a))) - 1, i)
k = 0
臨時文本 = 「」
j = 1
.判斷循環首 (i ≠ 0)
.如果真 (i % 2 = 1)
k = k + 1
臨時文本 = 臨時文本 + 到文本 (a [j])
.如果真結束
i = i ÷ 2
j = j + 1
.判斷循環尾 ()
.如果真 (k = n)
編輯框1.加入文本 (臨時文本 + #換行符)
.如果真結束
.計次循環尾 ()

Ⅶ 易語言遞歸演算法怎麼用,求高手給舉個簡單點的例子

遞歸,簡單說是子程序自己調用自己。
例子:
.版本 2
.子程序 左右查找
.參數 左邊值, 整數型
.參數 右邊值, 整數型
.參數 查找數組, , 數組
.參數 ww, , 參考 可空 數組
.局部變數 i, 整數型
.局部變數 j, 整數型
.局部變數 中間值, 整數型

.如果真 (左邊值 ≥ 右邊值)
返回 ()
.如果真結束
i = 左邊值
j = 右邊值
.判斷循環首 (j ≠ i)
.判斷循環首 (查找數組 [左邊值] ≤ 查找數組 [j] 且 i < j)
j = j - 1
.判斷循環尾 ()
.判斷循環首 (查找數組 [左邊值] ≥ 查找數組 [i] 且 i < j)
i = i + 1
.判斷循環尾 ()
.如果真 (i < j)
中間值 = 查找數組 [j]
查找數組 [j] = 查找數組 [i]
查找數組 [i] = 中間值
.如果真結束

.判斷循環尾 ()
中間值 = 查找數組 [左邊值]
查找數組 [左邊值] = 查找數組 [i]
查找數組 [i] = 中間值
左右查找 (左邊值, i - 1, 查找數組, ) ' 繼續處理左邊的,這里是個遞歸的過程
左右查找 (i + 1, 右邊值, 查找數組, ) ' 繼續處理右邊的,這里是個遞歸的過程
ww = 查找數組
' 以上是快速排序的代碼實現,核心所在是遞歸的過程。

Ⅷ 易語言中,如何把文本型的計算公式直接用於計算機計算

.版本 2

.支持庫 script


.子程序 __啟動窗口_創建完畢


腳本組件1.執行 (「function plus(a,b)」 + #換行符 + 「{」 + #換行符 + 「return parseInt(a)+parseInt(b);」 + #換行符 + 「}」 + #換行符 + 「function concat(a,b)」 + #換行符 + 「{」 + #換行符 + 「return a+b;」 + #換行符 + 「}」)



.子程序 _按鈕1_被單擊


.如果真 (編輯框1.內容 ≠ 「」)

編輯框2.內容 = 腳本組件1.計算表達式 (編輯框1.內容)

.如果真結束


需要用到一個腳本組件

Ⅸ 易語言如何自動計算

兩種方法:

第一種:獲得焦點需要輸入完數字後點擊下編輯框3得到所需結果

.版本2

.子程序_編輯框3_獲得焦點

編輯框3.內容=到文本(到數值(編輯框1.內容)×到數值(編輯框2.內容))

第二種:內容被改變只要編輯框1或編輯框2中任意一個編輯框內容發生變化,編輯框3將自動計算結果!

.版本2

.子程序_編輯框1_內容被改變

編輯框3.內容=到文本(到數值(編輯框1.內容)×到數值(編輯框2.內容))

.子程序_編輯框2_內容被改變

編輯框3.內容=到文本(到數值(編輯框1.內容)×到數值(編輯框2.內容))

呵呵呵,樓下在開玩笑么?我的代碼沒有問題.你所說的無限執行根本不存在,你看好子程序名,內容被改變時執行,也就是說,如果你輸入數值進去,編輯框3才會執行操作,而停止輸入數值後,編輯框3也隨之子程序限定 停止執行操作!

熱點內容
安卓設備沒有藍牙怎麼辦 發布:2022-11-29 22:33:37 瀏覽:404
大型網站php 發布:2022-11-29 22:32:44 瀏覽:836
qq動態密碼一般是多少 發布:2022-11-29 22:29:57 瀏覽:819
里世界解壓密碼acg 發布:2022-11-29 22:23:02 瀏覽:716
hxd是什麼品牌的密碼鎖 發布:2022-11-29 22:22:54 瀏覽:46
忘記密碼如何更改微信號 發布:2022-11-29 22:22:43 瀏覽:214
老是編譯出錯怎麼辦 發布:2022-11-29 22:21:49 瀏覽:984
雙倍工資怎麼演算法 發布:2022-11-29 22:20:06 瀏覽:557
頁面訪問升級日本 發布:2022-11-29 22:15:39 瀏覽:371
excel表格圖片壓縮 發布:2022-11-29 22:13:01 瀏覽:823