當前位置:首頁 » 雲伺服器 » 思科伺服器怎樣配置ip地址

思科伺服器怎樣配置ip地址

發布時間: 2022-12-07 03:59:43

Ⅰ 思科IP-MAC地址綁定怎麼配置

思科cisco製造的路由器設備、交換機和其他設備承載了全世界80%的互聯網通信,成為矽谷中新經濟的傳奇,那麼你知道思科IP-MAC地址綁定怎麼配置嗎?下面是我整理的一些關於思科IP-MAC地址綁定怎麼配置的相關資料,供你參考。

思科IP-MAC地址綁定配置的 方法 一、基於埠的MAC地址綁定

思科2950交換機為例,登錄進入交換機,輸入管理口令進入配置模式,敲入命令

Switch#c onfig terminal

進入配置模式

Switch(config)# Interface fastethernet 0/1

#進入具體埠配置模式

Switch(config-if)#Switchport port-secruity

#配置埠安全模式

Switch(config-if )switchport port-security mac-address MAC(主機的MAC地址)

#配置該埠要綁定的主機的MAC地址

Switch(config-if )no switchport port-security mac-address MAC(主機的MAC地址)

#刪除綁定主機的MAC地址

思科IP-MAC地址綁定配置的方法 二、基於MAC地址的擴展訪問列表

Switch(config)Mac access-list extended MAC

#定義一個MAC地址訪問控制列表並且命名該列表名為MAC

Switch(config)permit host 0009.6bc4.d4bf any

#定義MAC地址為0009.6bc4.d4bf的主機可以訪問任意主機

Switch(config)permit any host 0009.6bc4.d4bf

#定義所有主機可以訪問MAC地址為0009.6bc4.d4bf的主機

Switch(config-if )interface Fa0/20

#進入配置具體埠的模式

Switch(config-if )mac access-group MAC in

#在該埠上應用名為MAC的訪問列表(即前面我們定義的訪問策略)

Switch(config)no mac access-list extended MAC

#清除名為MAC的訪問列表

思科IP-MAC地址綁定配置的方法 三、IP地址的MAC地址綁定

只能將應用1或2與基於IP的訪問控制列表組合來使用才能達到IP-MAC 綁定功能。

Switch(config)Mac access-list extended MAC

#定義一個MAC地址訪問控制列表並且命名該列表名為MAC

Switch(config)permit host 0009.6bc4.d4bf any

#定義MAC地址為0009.6bc4.d4bf的主機可以訪問任意主機

Switch(config)permit any host 0009.6bc4.d4bf

#定義所有主機可以訪問MAC地址為0009.6bc4.d4bf的主機

Switch(config)Ip access-list extended IP

#定義一個IP地址訪問控制列表並且命名該列表名為IP

Switch(config)Permit 192.168.0.1 0.0.0.0 any

#定義IP地址為192.168.0.1的主機可以訪問任意主機

Permit any 192.168.0.1 0.0.0.0

#定義所有主機可以訪問IP地址為192.168.0.1的主機

Switch(config-if )interface Fa0/20

#進入配置具體埠的模式

Switch(config-if )mac access-group MAC1in

#在該埠上應用名為MAC的訪問列表(即前面我們定義的訪問策略)

Switch(config-if )Ip access-group IP in

#在該埠上應用名為IP10的訪問列表(即前面我們定義的訪問策略)

Switch(config)no mac access-list extended MAC

#清除名為MAC的訪問列表

Switch(config)no Ip access-group IP in

#清除名為IP的訪問列表

在cisco交換機中為了防止ip被盜用或員工亂改ip,可以做以下 措施 ,即ip與mac地址的綁定和ip與交換機埠的綁定。

通過IP查埠

先查Mac地址,再根據Mac地址查埠

bangonglou3#show arp | include 208.41 或者show mac-address-table 來查看整個埠的ip-mac表

Internet 10.138.208.41 4 0006.1bde.3de9 ARPA Vlan10

bangonglou3#show mac-add | in 0006.1bde

10 0006.1bde.3de9 DYNAMIC Fa0/17

bangonglou3#exit

ip與mac地址的綁定,這種綁定可以簡單有效的防止ip被盜用,別人將ip改成了你綁定了mac地址的ip後,其網路不同,

(tcp/udp協議不同,但netbios網路共項可以訪問),具體做法:

cisco(config)#arp 10.138.208.81 0000.e268.9980 ARPA

這樣就將10.138.208.81 與mac:0000.e268.9980 ARPA綁定在一起了

ip與交換機埠的綁定,此種方法綁定後的埠只有此ip能用,改為別的ip後立即斷網。有效的防止了亂改ip.

cisco(config)# interface FastEthernet0/17

cisco(config-if)# ip access-group 6 in

cisco(config)#access-list 6 permit 10.138.208.81

這樣就將交換機的FastEthernet0/17埠與ip:10.138.208.81綁定了。

Ⅱ 思科交換機怎麼給埠配置ip

1、在思科模擬器上找到Cisco 2960交換機一台,PC 2台,直通線若干條,進行連接配置。

注意事項:

交換機根據工作位置的不同,可以分為廣域網交換機和區域網交換機。廣域的交換機就是一種在通信系統中完成信息交換功能的設備,它應用在數據鏈路層。交換機有多個埠,每個埠都具有橋接功能,可以連接一個區域網或一台高性能伺服器或工作站。實際上,交換機有時被稱為多埠網橋。

Ⅲ 求教Cisco思科路由器的ip地址配置

首先,你的伺服器的的網關地址不能是自己,你這里必須是10.1.1.2,
其次,你需要在核心和路由器上寫路由,分別如下:
核心:
ip
route
0.0.0.0
0.0.0.0
192.168.4.6
路由器:
ip
route
192.168.0.0
255.255.0.0
192.168.4.1

Ⅳ 如何配置Cisco交換機的IP地址

大家知道如何配置Cisco交換機的IP地址的方法么?接下來是我為大家收集的如何配置Cisco交換機的IP地址方法,希望能幫到大家。
如何配置Cisco交換機的IP地址的方法
1. 計算機命令:

PCA login: root ;使用root用戶

password: linux ;口令是linux

# shutdown -h now ;同init 0 關機

# logout

# login

# ifconfig ;顯示IP地址

# ifconfig eth0 netmask ;設置IP地址

# ifconfig eht0 netmask down ; 刪除IP地址

# route add 0.0.0.0 gw

# route del 0.0.0.0 gw

# route add default gw ;設置網關

# route del default gw ;刪除網關

# route ;顯示網關

# ping

# telnet

2. 交換機支持的命令:

交換機基本狀態:

switch: ;交換機的ROM狀態

rommon> ;路由器的ROM狀態

hostname> ;用戶模式

hostname# ;特權模式

hostname(config)# ;全局配置模式

hostname(config-if)# ;介面狀態

交換機口令設置:

switch>enable ;進入特權模式

switch#config terminal ;進入全局配置模式

switch(config)#hostname ;設置交換機的主機名

switch(config)#enable secret xxx ;設置特權加密口令

switch(config)#enable password xxa ;設置特權非密口令

switch(config)#line console 0 ;進入控制台口

switch(config-line)#line vty 0 4 ;進入虛擬終端

switch(config-line)#login ;允許登錄

switch(config-line)#password xx ;設置登錄口令xx

switch#exit ;返回命令

交換機VLAN設置:

switch#vlan database ;進入VLAN設置

switch(vlan)#vlan 2 ;建VLAN 2

switch(vlan)#no vlan 2 ;刪vlan 2

switch(config)#int f0/1 ;進入埠1

switch(config-if)#switchport access vlan 2 ;當前埠加入vlan 2

switch(config-if)#switchport mode trunk ;設置為干線

switch(config-if)#switchport trunk allowed vlan 1,2 ;設置允許的vlan

switch(config-if)#switchport trunk encap dot1q ;設置vlan 中繼

switch(config)#vtp domain ;設置發vtp域名

switch(config)#vtp password ;設置發vtp密碼

switch(config)#vtp mode server ;設置發vtp模式

switch(config)#vtp mode client ;設置發vtp模式

交換機設置IP地址:

switch(config)#interface vlan 1 ;進入vlan 1

switch(config-if)#ip address ;設置IP地址

switch(config)#ip default-gateway ;設置默認網關

switch(config)#no shutdown

switch#dir flash: ;查看快閃記憶體

交換機顯示命令:

switch#write ;保存配置信息

switch#show vtp ;查看vtp配置信息

switch#show run ;查看當前配置信息

switch#show vlan ;查看vlan配置信息

switch#show interface ;查看埠信息

switch#show int f0/0 ;查看指定埠信息

3. 路由器支持的命令:

路由器顯示命令:

router#show run ;顯示配置信息

router#show interface ;顯示介面信息

router#show ip route ;顯示路由信息

router#show cdp nei ;顯示鄰居信息

router#reload ;重新起動

路由器口令設置:

router>enable ;進入特權模式

router#config terminal ;進入全局配置模式

router(config)#hostname ;設置交換機的主機名

router(config)#enable secret xxx ;設置特權加密口令

router(config)#enable password xxb ;設置特權非密口令

router(config)#line console 0 ;進入控制台口

router(config-line)#line vty 0 4 ;進入虛擬終端

router(config-line)#login ;要求口令驗證

router(config-line)#password xx ;設置登錄口令xx

router(config)#(Ctrl+z) ; 返回特權模式

router#exit ;返回命令

路由器配置:

router(config)#int s0/0 ;進入Serail介面

router(config-if)#no shutdown ;激活當前介面

router(config-if)#clock rate 64000 ;設置同步時鍾

router(config-if)#ip address ;設置IP地址

router(config-if)#ip address second ;設置第二個IP

router(config-if)#int f0/0.1 ;進入子介面

router(config-***if.1)#ip address ;設置子介面IP

router(config-***if.1)#encapsulation dot1q ;綁定vlan中繼協議

router(config)#config-register 0x2142 ;跳過配置文件

router(config)#config-register 0x2102 ;正常使用配置文件

router#reload ;重新引導

路由器文件操作:

router# running-config startup-config ;保存配置

router# running-config tftp ;保存配置到tftp

router# startup-config tftp ;開機配置存到tftp

router# tftp flash: ;下傳文件到flash

router# tftp startup-config ;下載配置文件

ROM狀態:

Ctrl+Break ;進入ROM監控狀態

rommon>confreg 0x2142 ;跳過配置文件

rommon>confreg 0x2102 ;恢復配置文件

rommon>reset ;重新引導

rommon> xmodem: flash: ;從console傳輸文件

看了“如何配置Cisco交換機的IP地址”還想看:

1. 思科cisco怎麼配置WEB網管

2. cisco交換機設置

3. 思科IP-MAC地址綁定怎麼配置

4. 交換機如何配置telnet

5. cisco交換機怎麼配置vlan

Ⅳ 思科交換機怎麼給埠配置ip

1、在思科模擬器上找到Cisco 2960交換機一台,PC 2台,直通線若干條,進行連接配置。

注意事項:

交換機根據工作位置的不同,可以分為廣域網交換機和區域網交換機。廣域的交換機就是一種在通信系統中完成信息交換功能的設備,它應用在數據鏈路層。交換機有多個埠,每個埠都具有橋接功能,可以連接一個區域網或一台高性能伺服器或工作站。實際上,交換機有時被稱為多埠網橋。

Ⅵ 思科路由器設置ip地址怎麼設置

思科路由器設置ip地址需要登錄交換機ios系統,通過console線,首先en進入特權模式,sh ip int bri查看埠信息列表。
然後進入全局配置模式conf t,int+埠號 進入介面配置模式,ip add 命令為埠配置ip地址,最好介面識圖下敲no sh命令激活埠。這樣ip地址配置完畢,特別是最後一個no sh操作不能省去。

Ⅶ 思科路由器設置ip地址怎麼設置

步驟如下:

1、首先在電腦上點擊打開Cisco軟體。然後選擇一台電腦還有一個路由器。

Ⅷ 思科路由器設置ip地址怎麼設置

方法
1、對著電腦右下邊的
電腦圖標
點擊右鍵,再點擊「打開網路和共享中心」進入(如下圖):
2、進入「打開網路和共享中心」,點擊打開「本地連接」(如下圖):
3、在本地鏈接界面上點擊打開「詳細信息」(如下圖):
4、這個時候就查看到了計算機的IP地址(如下圖):
5、如果是192.168.1.x,則跳過後續步驟,如果不是的,則手動修改為192.168.1.2(如下圖):
6、然後在網頁上打開http://192.168.1.1,輸入
路由器
登錄賬號和密碼(可以在路由器上面查看初始密碼,如果修改過,則用自己修改過的密碼)(如下圖):
7、登錄成功後,找到「內部網路」,「內網地址設置」,即可修改路由器IP地址了(如下圖):

Ⅸ Cisco路由器如何設置管理IP地址

Cisco路由器設置ip地址方法如下:
一、自動設置IP地址,使用DHCP伺服器功能
DHCP是路由器的一個特殊功能,使用DHCP功能可以避免因手工設置IP地址及子網掩碼所產生的錯誤。
(1)單擊「開始」按鈕中的「控制面板」,在「控制面板」窗口中打開「網路連接」,右鍵單擊「本地連接」,選擇「屬性」選項,在屬性對話框中雙擊「Internet協議(TCP/IP)」,單擊「自動獲得IP地址」,單擊「確定」;

(2)在路由器管理界面單擊左側的「DHCP伺服器」選項,在彈出的「DHCP設置」窗口中,單擊「啟用」按鈕。「地址池開始地址」和「地址池結束地址」選項IP地址的第4段是用戶可以任意輸入的部分。我們可以分別輸入100、200(需要注意的是輸入的開始地址必需小於結束地址,而且開始地址不能是0、1,結束地址不能是255);

(3)設置完畢後單擊「保存」按鈕。關閉計算機和路由器,斷開電源後重新打開,再次啟動計算機即可。
二、手動設置IP地址
(1) 單擊「開始」按鈕中的「控制面板」,在「控制面板」窗口中打開「網路連接」,右鍵單擊「本地連接」,選擇「屬性」選項,在屬性對話框中雙擊「Internet協議(TCP/IP)」;

(2)單擊「使用下面的IP地址」,輸入IP地址192.168.1.X(X范圍2-254)、子網掩碼255.255.255.0、默認網關192.168.1.1,確定即可。

熱點內容
ftp教程linux技術 發布:2023-02-01 03:26:24 瀏覽:136
java資料庫隊列 發布:2023-02-01 03:26:12 瀏覽:26
新電腦配置怎麼樣 發布:2023-02-01 03:24:31 瀏覽:814
卡盟內頁腳本 發布:2023-02-01 03:22:15 瀏覽:348
easyui緩存 發布:2023-02-01 03:21:26 瀏覽:67
都哪個牌子安卓機用久了不卡 發布:2023-02-01 03:19:46 瀏覽:610
感冒後上傳 發布:2023-02-01 03:18:05 瀏覽:1000
壓縮寶寶 發布:2023-02-01 03:13:35 瀏覽:259
sip伺服器需開什麼埠 發布:2023-02-01 03:11:50 瀏覽:644
c語言全形 發布:2023-02-01 03:10:51 瀏覽:215