當前位置:首頁 » 操作系統 » 易語言資料庫查詢

易語言資料庫查詢

發布時間: 2022-08-18 09:50:28

『壹』 易語言資料庫查找

.版本 2
.常量 資料庫1, "「資料庫」"
.常量 出差時間, "「出差時間」"
.常量 出差地點, "「出差地點」"
.常量 出差人員, "「出差人員」"
.版本 2
.支持庫 iext
.程序集 窗口程序集1
.子程序 __啟動窗口_創建完畢
打開 (#資料庫1, , , , , , )
.子程序 _查詢按鈕_被單擊
.局部變數 計次, 整數型
.局部變數 開始日期, 日期時間型
.局部變數 結束日期, 日期時間型
.局部變數 行, 整數型
.局部變數 id, 日期時間型
超級列表框1.全部刪除 ()
開始日期 = 日期框1.今天
結束日期 = 日期框2.今天
計次 = 取記錄數 ()
到首記錄 ()
.計次循環首 (計次, )
id = 讀 (#出差時間)
.判斷開始 (查找 (id ≥ 開始日期 且 id ≤ 結束日期))
行 = 超級列表框1.插入表項 (-1, , , , , )
超級列表框1.置標題 (行, 0, 到文本 (id))
超級列表框1.置標題 (行, 1, 讀 (#出差地點))
超級列表框1.置標題 (行, 2, 讀 (#出差人員))
.默認
.判斷結束
跳過 ()
.計次循環尾 ()

『貳』 易語言查詢資料庫然後寫出文本內容(來個大神解救下)

上面的命令再看看用法就可以用了,,不難,

『叄』 如何查詢易語言資料庫中的值

易語言的資料庫的話:
例如
跳到(1)
『從資料庫首開始
判斷(查找(讀(#賬號)=編輯框1.內容))
』查找賬號是否存在
|__|__判斷(讀欄位(#密碼)=編輯框2.內容)
|
|___
信息框(「登陸成功!」)『查找到賬號後,資料庫指針停止在
|
該記錄。所以可以用讀欄位讀取賬號對應的密碼。。看看
|
用戶輸入的密碼是否正確
|
|
|
____信息框(「沒有該賬號」)
ACCESS又是另一種方法...我就不寫出來了

『肆』 易語言資料庫查詢

好了,給你寫好並且測試了,用得外部資料庫!
外部資料庫的名稱為:外部資料庫1
.版本 2

.局部變數 索引, 整數型

外部資料庫1.打開MDB資料庫 (取運行目錄 () + 「\123.mdb」, , , , )
索引 = 外部資料庫1.查詢 (「select user from 123」)
.如果 (索引 ≠ 0)
外部資料庫1.到首記錄 (索引)
.判斷循環首 (外部資料庫1.尾記錄後 (索引) = 假)
.如果真 (到文本 (外部資料庫1.讀 (索引, 1)) = 「123456」)
信息框 (「用戶存在」, 0, )
返回 ()
.如果真結束
外部資料庫1.到後一記錄 (索引)
.判斷循環尾 ()
.否則
信息框 (「查詢失敗」, 0, )
返回 ()
.如果結束
信息框 (「用戶不存在」, 0, )

能行就給分吧!

『伍』 易語言edb資料庫查找

打開(資料庫1)
判斷循環首 (查找 (讀 (1) =編輯框1.內容))
要執行的命令
跳過 ()
判斷循環尾 ()

『陸』 易語言edb資料庫 里的 查找 怎麼用啊

我猜想#姓名應該是資料庫欄位名,正確的語法應該是:查找(讀("姓名")="程序")
如果欄位類型為文本型的可用 編輯框1.內容=讀("年齡") 如果是其他類型的需轉換到文本型,本常式應改為:
跳到(1)'為了保證每次均從庫文件的首記錄開始進行查找,首先將針指置於首記錄
如果真(查找(讀("姓名")="程序")=假)
信息框("沒有匹配的姓名",0,"錯誤")
返回()
如果真結束
編輯框1.內容=到文本(讀("年齡"))

其中:「姓名」和「年齡」均為該資料庫的欄位名(本例假設姓名為文本型,年齡為整數型)

『柒』 易語言edb資料庫保存、修改、刪除、查詢

1、請打開易語言。

『捌』 易語言如何查詢excel資料庫拜託各位大神

.版本 2 .支持庫 eExcel2000 Excel工作簿1.置程序 (Excel程序1) ' 設置工作簿於excel程序領導之下 Excel工作簿1.打開 (取當前目錄 () +「\」 + 年級數 +「.xls」) ' 本來可以加個文件名的,如果沒有文件,則另存為吧. Excel工作簿1.表格序號 = 1 ' 設置第一張表為工作表. Excel程序1.顯示 =真 ' 以下是把資料庫中的查詢結果放入excel程序里 tempnum = 1 ' 第一條記錄 tempnumtext = 到文本 (tempnum) 外部資料庫1.到首記錄 (記錄集句柄1) .判斷循環首 (外部資料庫1.尾記錄後 (記錄集句柄1) =假) ' 是不是已經到了尾記錄了.如果不是,繼續. .變數循環首 (1, 33, 1, loopnum) ' 共有33個欄位,每行顯示33段,在excel表中表示列.tempnum表示為行 Excel工作簿1.首單元格 = 表列數組 [loopnum] + tempnumtext Excel工作簿1.尾單元格 = 表列數組 [loopnum] + tempnumtext Excel工作簿1.內容格式 =「@」 ' 這代表是文本型的數據.本行可讀可寫,你可以先設置好格式,然後讀一下,顯示是什麼,再設置 Excel工作簿1.內容 = 外部資料庫1.讀 (記錄集句柄1, loopnum) .變數循環尾 () 外部資料庫1.到後一記錄 (記錄集句柄1) tempnum = tempnum + 1 tempnumtext = 到文本 (tempnum) .判斷循環尾 () ' Excel工作簿1.保存 (取當前目錄 () +「\」 + 年級數 +「.xls」) ' Excel工作簿1.關閉 () ' Excel程序1.退出 ()

熱點內容
怎麼用紙做豌豆解壓玩具 發布:2022-09-29 04:39:17 瀏覽:728
雲存儲播放時間表 發布:2022-09-29 03:58:31 瀏覽:598
新英朗4缸買哪個配置劃算 發布:2022-09-29 03:51:54 瀏覽:121
紅旗5配置怎麼選 發布:2022-09-29 03:44:21 瀏覽:886
linux安裝maven 發布:2022-09-29 03:29:18 瀏覽:595
吉利星瑞豪華天窗版有什麼功能配置 發布:2022-09-29 03:20:28 瀏覽:816
伺服器固定ip和彈性ip一起用 發布:2022-09-29 02:40:49 瀏覽:506
gpioc語言 發布:2022-09-29 02:34:40 瀏覽:951
h乚c語言 發布:2022-09-29 02:34:39 瀏覽:410
迷你世界體驗服正式服密碼是多少 發布:2022-09-29 02:21:19 瀏覽:419