當前位置:首頁 » 操作系統 » 高點公式源碼

高點公式源碼

發布時間: 2022-08-13 17:52:19

1. 求高手編寫通達信放量突破前期高點的選股公式

通達信放量突破前期高點的選股公式:a1:=hhv(h,80);cross(h,ref(a1,1));這是突破前期80日高點為例寫的,可以將80更換;
通達信公式操作指南:
1、指標分析:
"公式編輯器"好比是一個工作母床,通過這個工作母床可以製造出所需要的各式各樣的零件,同樣,在指標分析的工作中,利用編輯器可以編寫出相應的分析條件,這種方法是在技術分析當中最為常用的方法之一。例如,指標KD、指標MA等等,通過對這些指標的觀察、分析,找出一些合適的條件作為買入賣出點。
2、條件選股:
(1)技術指標:
MA均線就是一種技術指標,在炒股的時候,經常會將一些行情數據進行數學計算得出一些曲線等等,方便我們掌握股市的變動情況。
(2)條件選股:
簡單講,就是按照您的設定的條件用電腦幫助您完成一些太多太復雜的挑選--比如您有一些好的心得和方法,可是有1000多隻股票,您就是有100雙眼睛有時也不一定可以看得過來,這時電腦就派上用場了。
(3)參數
比如講:10日均線,您可以把10日當作參數,好處在於,您覺得需要修改成5日的時候,就可以使用一些簡單的方法,例如參數精靈來很方便的修改和調整。參數需要名字,例如M就不錯。還要規定參數的范圍,例如1日至260日。這樣我們就可以在1到260之間任意調節M的值了,M最常用的數據在"預設"一欄。
(4)周期
有的投資者喜歡使用日線圖作技術分析;有的喜歡用5分鍾的K線;有的喜歡使用長一段時間的,例如周線。所以在公式設計中,允許不同喜好的使用者選擇不同的分析時間--就是可以選擇不同的周期。
(5)函數
函數在公式編寫非常重要,如果作個比喻,我們用一種語言去告訴電腦我的想法,並且讓它去幫我做,那麼函數就是這種語言的單詞。我們在公式編輯器中選擇插入函數,就可以看到裡面有許多的函數,

2. 股價突破近期下降趨勢高點連線並且在60日均線之上的通達信選股公式源碼

你是想找突破下降趨勢,並且改成上升趨勢的股票吧我感覺你提的高點連線沒用,因為每2個高點連線都可以為一個趨勢線,這樣你還是得一個一個看趨勢線是不是有效的, 站上60天線來判定處於上升趨勢也並不可靠,在長時間下跌時,反彈經常可以過60線,按你的表達,這個公式做出來我想實用意義不大如果你有更好的方法來表示趨勢線,我可以幫你寫出這個公式,

3. 求 通達信 高手 編寫 主圖 高點和高點 畫線公式 低點和低點畫線公式

通達信可以編寫兩個高點連線並且延長,兩個低點連線並且延長,也可以顯示成虛線,但這個看起來應該比較亂這點要注意,我沒有你的源碼,那就找一個高點指標公式是一個效果,高點連線顯示黃色虛線,低點連線顯示綠色虛線。

效果如下圖。

4. 秒殺一切妖股指標公式源碼是什麼

如下:

{百底公式1}

{AB:=EMA(((2*C+H+L)/4-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,8);

BA:=EMA(AB,5);

頂1:=REFDATE(REF(HHV(H,100),5),DATE);

底1:=REFDATE(REF(LLV(L,100),5),DATE);

中1:=((頂1)+(底1))/2;

頂:IF(AB>0 AND AB-BA<=0,頂1,頂1),COLOR00FF00;

中:IF(AB>0 AND AB-BA<=0,中1,中1),COLORWHITE;

底:IF(AB>0 AND AB-BA<=0,底1,底1),COLORYELLOW;

DRAWTEXT(ISLASTBAR,(頂),STRCAT('',CON2STR(頂,2))),COLORWHITE;

DRAWTEXT(ISLASTBAR,(中),STRCAT('',CON2STR(中,2))),COLORWHITE;

DRAWTEXT(ISLASTBAR,(底),STRCAT('',CON2STR(底,2))),COLORWHITE;

{百底公式2}

N:100 NODRAW ;

高:IF(CURRBARSCOUNT<=N,CONST(HHV(H,N)),DRAWNULL),COLORGREEN ;

低:IF(CURRBARSCOUNT<=N,CONST(LLV(L,N)),DRAWNULL),COLORYELLOW;

NOTEXT中:低+(高-低)/2 COLORWHITE;

{漲幅:(C-低)/低*100 NODRAW COLORFF00FF;}

漲幅:((C-低)/(高-低))*100 NODRAW COLORFF00FF;

漲天數:LLVBARS(L,100)COLORWHITE NODRAW;

{跌幅:((C-高)/高)*100 NODRAW COLORD9D919;};

跌幅:((C-高)/(高-低))*100 NODRAW COLORD9D919;

跌天數:HHVBARS(H,100)COLORWHITE NODRAW;

DRAWTEXT(ISLASTBAR,(高-(高-低)/50),STRCAT('',CON2STR(高-(高-低)/50,2))),COLORWHITE;

DRAWTEXT(ISLASTBAR,(NOTEXT中),STRCAT('',CON2STR(NOTEXT中,2))),COLORWHITE;

DRAWTEXT(ISLASTBAR,(低),STRCAT('',CON2STR(低,2))),COLORWHITE;

MA5:MA(C,5),COLORYELLOW;

NOTEXT5:IF((C<=MA5 OR MA5<=REF(MA5,1)),MA5,DRAWNULL),COLORFFFF00;

振幅:((高-低)/低)*100 NODRAW COLORGREEN;

均周月:INBLOCK('均周')AND INBLOCK('均月') COLORWHITE NODRAW;

逃周月:INBLOCK('逃周')AND INBLOCK('逃月')NODRAW COLORYELLOW;

{VAR6:=REF(C,1);

VAR7:=SMA(MAX(C-VAR6,0),6,1)/SMA(ABS(C-VAR6),6,1)*100;

DRAWTEXT(CROSS(82,VAR7),H*1.01,'高拋'),COLORFFFFFF;

VAR1:=LLV(LOW,21);

VAR2:=HHV(HIGH,21);

AK1:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 100),5);

AK:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 50),13);

AB:=CROSS(AK1,AK);

DRAWTEXT((AB = 1),(LOW * 0.99),'低吸'),COLORYELLOW;};

{百底距:=((C-低)/低)*100;

XG1:=BETWEEN(C,低,低*(1+0.03));

盤整天:BARSLASTCOUNT(XG1)NODRAW COLORYELLOW;}

{上漲值:=MA((H+REF(L,1))/2,3);

買進高點:=MA((H+REF(H,1))/2,3);

VAR1:=((O+H+L+2*C)/5)*2-L;

突破買入值:=MA(VAR1,3);{LSS軸點突破買入值}

{下跌值:=MA((REF(H,1)+L)/2,3);

賣出低點:=MA((REF(L,1)+L)/2,3);

VAR2:=((O+H+L+2*C)/5)*2-H;

突破賣出值:=MA(VAR2,3);

次日賣出點:=(上漲值+買進高點+突破買入值+H)/4;

次日買入點:=(下跌值+賣出低點+突破賣出值+L)/4;

均價:=(2*C+L+H/4);

買入價:IF(均價/REF(均價,1)>1,次日買入點*1.01,次日買入點)COLORWHITE NODRAW;

次低價:IF(均價/REF(均價,1)>1,次日買入點/1.0382,次日買入點)NODRAW COLORYELLOW;

賣出價:IF(均價/REF(均價,1)>1,次日賣出點*1.0191,次日賣出點)NODRAW;

必賣價:IF(均價/REF(均價,1)>1,次日賣出點*1.05,次日賣出點)COLORD9D919 NODRAW;}

{AC:=REF(C,1);

漲停K線:=IF((C-AC)*100/AC>=(10-0.01*100/AC),1,0);

跌停K線:=IF((AC-C)*100/AC>=(10-0.01*100/AC),1,0);

STICKLINE(漲停K線,OPEN,CLOSE,2.5,0),COLORYELLOW;

STICKLINE(跌停K線,OPEN,CLOSE,2.5,0),COLORED9564;}

{漲停顏色粉色,完美區分20%10%5%,創業板20200823前10%照樣變色}

BK:=IF(INBLOCK('科創板'),0.2,IF(INBLOCK('創業板'),0.2,IF(INBLOCK('ST板塊'),0.05,0.1)));

XA_1:=IF(DATE<=1200823,1,0);

STICKLINE((C>=ZTPRICE(REF(CLOSE,1),0.1) AND C=H) AND XA_1=1,O,C,3,0),COLORYELLOW;

STICKLINE((C<=DTPRICE(REF(CLOSE,1),0.1) AND C=L) AND XA_1=1,O,C,3,0),COLORED9564;

STICKLINE((C>=ZTPRICE(REF(C,1),BK) AND C=H),C,O,3,0),COLORYELLOW;

STICKLINE((C<=DTPRICE(REF(C,1),BK) AND C=L),C,O,3,0),COLORED9564;

{STICKLINE((H>=ZTPRICE(REF(C,1),BK) AND C<H) OR (H>=ZTPRICE(REF(CLOSE,1),0.1) AND C<H AND XA_1=1),H,MAX(C,O),0.1,0),COLORYELLOW;{漲停後回落}

{STICKLINE((L<=DTPRICE(REF(C,1),BK) AND C>L) OR (L<=DTPRICE(REF(CLOSE,1),0.1) AND C>L AND XA_1=1),L,MIN(C,O),0.1,0),COLORED9564;{跌停後回升}

{Z1:=STRCAT(HYBLOCK,' ');

Z2:=STRCAT(Z1,DYBLOCK);

Z3:=STRCAT(Z2,' ');

DRAWTEXT_FIX(ISLASTBAR,0,10,0,STRCAT(Z3,GNBLOCK)),COLORWHITE;}

{DRAWTEXT_FIX(1,0.00,0.00,0,'主題投資:')COLORYELLOW;

DRAWTEXT_FIX(1,0.06,0.00,0,EXTERNSTR(0,1))COLORYELLOW;

DRAWTEXT_FIX(1,0.00,0.06,0,'主營業務:')COLORWHITE;

DRAWTEXT_FIX(1,0.06,0.06,0,EXTERNSTR(0,2))COLORWHITE;

DRAWTEXT_FIX(1,0.00,0.12,0,'公司亮點:')COLORYELLOW;

DRAWTEXT_FIX(1,0.06,0.12,0,EXTERNSTR(0,3))COLORYELLOW; }

{流通市值:(FINANCE(40)/100000000),NODRAW,COLORRED;}

{漲停統計}

{漲停:=CLOSE/REF(CLOSE,1)>=1.095;

ZTCS:=COUNT(漲停,BARSSINCE(漲停)+1);}

{DRAWNUMBER(漲停,HIGH*1.04,ZTCS),COLORYELLOW;}

{GZT1:=STRCAT('共漲停: ',CON2STR(ZTCS,0));

GZT2:=STRCAT(GZT1,'次');

SSTS1:=STRCAT('上市: ',CON2STR(FINANCE(42),0));

SSTS2:=STRCAT(SSTS1,'天');

NTZZT1:=STRCAT('距今:',CON2STR(CONST(BARSLAST(漲停)),0));

NTZZT2:=STRCAT(NTZZT1,'天有漲停');

ZTTJ1:=STRCAT(SSTS2,GZT2);

ZTTJ2:=STRCAT(ZTTJ1,NTZZT2);

ZTTJ:=STRCAT('漲停統計:',ZTTJ2);

DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0.18,0,ZTTJ),COLORWHITE;}。

5. 通達信選股指標公式

通達信選股公式1、多方炮TJ1:=COANDC=HAND(C-REF(C,1))REF(C,1)100=5;TJ2:=VOLTJ4:=EVERY(MAX(C,O)MA(C,7),3)ANDCAPITAL10000007;TJ3:=COANDC=H;XG:TJ1ANDREF(TJ2,1)ANDREF(TJ3,2)ANDTJ4;

通達信選股公式2、向上跳空缺口三天不回補選股公式:XSTK:=LOWREF(HIGH,1);TT1:=BARSLAST(XSTK)+1;HH:=REF(HIGH,TT1);不回補:=TT1=3ANDCOUNT(XSTK,TT1)=1ANDLOWHHANDLOW=HH1.01ANDNOT(EXIST(CROSS(HH,LOW),TT1));COUNT(LOWREF(HIGH,1),3)0AND不回補;

通達信選股公式3、向上跳空缺口當天不回補選股公式:XSTK:=LOWREF(HIGH,1);TT1:=BARSLAST(XSTK)+1;HH:=REF(HIGH,TT1);不回補:=TT1=1ANDCOUNT(XSTK,TT1)=1ANDLOWHHANDLOW=HH1.001ANDNOT(EXIST(CROSS(HH,LOW),TT1));缺口:=LOW=HH1.001;去ST:=IF(NAMELIKE('ST'),0,1)ANDIF(NAMELIKE('S'),0,1)ANDIF(DYNAINFO(9)=0,0,1){停牌};未補:COUNT(LOWREF(C,1),3)0AND不回補AND去ST;

通達信選股公式4、錘子線選股公式B:=IF(CO,O,C);B1:=IF(CO,C,O);錘子線選股:if((B-L)ABS(C-O)=2and(H-B1)ABS(C-O)1andco,1,0);

通達信選股公式5、啟明星+選股預警公式{啟明星}VARF1:=TROUGHBARS(3,15,1)4;DRAWTEXT(FILTER(VARF1=1,3),48.8,'啟明星'),COLORRED;空:=EMA((CLOSE-MA((2CLOSE+HIGH+LOW)4,30))MA((2CLOSE+HIGH+LOW)4,30)100,3),COLORWHITE;STICKLINE(FILTER(VARF1=1,5)AND多空-10,60,0,3,0),COLORF00FF0;STICKLINE(FILTER(VARF1=1,5),60,0,1,0),COLORYELLOW。

通達信選股公式6、選股預警公式:VARF1:=TROUGHBARS(3,15,1)4;啟明星:FILTER(VARF1=1,3);

通達信選股公式7、平頭底部形態的選股公式K1:=ABS(LOW-REF(LOW,1))0.02;K2:=ABS(LOW-REF(LOW,2))0.02;K3:=ABS(LOW-REF(LOW,3))0.02;K4:=ABS(LOW-REF(LOW,4))0.02;K5:=ABS(LOW-LLV(LOW,5))0.02;K1ORK2ORK3ORK4ANDK5;20均線之上出現的平底(強勢股)K1:=ABS(LOW-REF(LOW,1))0.02;K2:=ABS(LOW-REF(LOW,2))0.02;K3:=ABS(LOW-REF(LOW,3))0.02;K4:=ABS(LOW-REF(LOW,4))0.02;K5:=LOWMA(C,20)ANDABS(LOW-LLV(LOW,5))0.02;K1ORK2ORK3ORK4ANDK5;用這個通達信選股公式選出來的股票,最好是回撤到前頭部止跌的,是絕對強勢,成功率極高。

拓展資料
通達信選股公式1.公式類型說明:調出公式管理器:功能à專家系統à公式管理器公式類型分為四大類:技術指標公式、條件選股公式、交易系統公式、五彩K線公式。

通達信選股公式1.1技術指標公式:我們在技術分析界面中見到的指標為技術指標公式,比如KDJ,MACD等;通過公式管理器編寫技術指標公式,在公式管理器界面選擇技術指標公式,點擊右邊的「新建」就可進入技術指標公式編輯區。通達信選股公式編寫?在指標公式編輯區,可以通過「引入指標公式」,在已有指標的基礎上修改指標公式,也可以通過插入函數來實現指標公式的編寫。

通達信選股公式1.2條件選股公式:利用條件選股公式可以把符合一定技術形態的個股選出來,首先在公式管理器中建立條件選股公式,再通過「條件選股」調用條件選股公式。

6. 通達信第一根季K高點公式

局部高點預選A:=BACKSET(HHV(H,5)>REF(HHV(H,4),1),4);
局部高點預選B:=BACKSET(局部高點預選A=0 AND REF(局部高點預選A,1)=1,2);
局部高點預選C:=IF(局部高點預選B=1 AND REF(局部高點預選B,1)=0,1,0);

7. 股票突破前期新高的選股公式源碼。

P1:=BARSLAST(HHV(REF(H,5),120)=REF(H,60-1+5))+60-1+5;
HHV(H,60)=H AND C>REF(H,P1) AND REF(H,1)<REF(H,P1);

熱點內容
安卓怎麼設置自動扣費 發布:2022-10-05 14:38:54 瀏覽:830
伺服器電腦桌面沒圖標 發布:2022-10-05 14:35:44 瀏覽:314
什麼是dns0伺服器 發布:2022-10-05 14:33:28 瀏覽:161
黑色隱藏字怎麼弄安卓 發布:2022-10-05 14:30:12 瀏覽:859
優酷加密視頻如何下載 發布:2022-10-05 14:30:11 瀏覽:996
忘記手繪密碼怎麼辦 發布:2022-10-05 14:30:10 瀏覽:604
海參的演算法 發布:2022-10-05 14:29:19 瀏覽:99
優酷怎麼不能緩存了 發布:2022-10-05 14:19:48 瀏覽:467
電腦配置低裝什麼系統 發布:2022-10-05 14:18:21 瀏覽:800
高級語言編譯後得到什麼程序 發布:2022-10-05 14:18:13 瀏覽:442