當前位置:首頁 » 操作系統 » 仿指標源碼

仿指標源碼

發布時間: 2022-09-24 17:19:00

⑴ 捉妖紅金綠指標公式源碼

以下是捉妖紅金綠指標公式源碼:
XA_3:=IF(NAMELIKE(3833)ORNAMELIKE(3834),0,1)。
XA_4:=DYNAINFO(4)>0。
XA_5:=XA_3ANDXA_4ANDXA_2。
XA_6:=EMA(CLOSE,9)。
XA_7:=(CLOSE+OPEN)/2。
XA_8:=MA(CLOSE,3)。
XA_9:=MA(CLOSE,2*3)。
XA_10:=MA(CLOSE,3*3)。
XA_11:=MA(CLOSE,4*3)。
XA_12:=MA((XA_8+XA_9+XA_10+XA_11)/4,5)。
XA_13:=EMA(XA_6*1.14,5)。
XA_14:=(EMA(XA_7,3)+EMA(XA_7,6)+EMA(XA_7,12)+EMA(XA_7,24))/4;
XA_15:=EMA(EMA(EMA(CLOSE,2),2),2)。
(1)仿指標源碼擴展閱讀
指標是說明總體數量特徵的概念。例如,在工業普查中,所有工業企業構成總體,工業企業總數、工業職工總數、工資總額、平均工資、固定資產總值、利潤總額等就是指標,它們都從不同的方面反映總體的數量特徵。
指標一般由指標名稱和指標數值兩部分組成,它體現了事物質的規定性和量的規定性兩個方面的特點。比如,經統計調查得知某企業固定資產原值為9.1億元人民幣,這就是指標,是說明總體綜合數量特徵的,它包括指標名稱即固定資產原值、指標數值即9.1億元人民幣兩個方面。

⑵ 仿指南針指標公式改個選股器

可以將這仿指南針指標改剛好第二天翻紅的選股。但這程序代碼應該找編程人員去編寫。普通人應該都不會寫的。

⑶ 秒殺一切妖股指標公式源碼是什麼

如下:

{百底公式1}

{AB:=EMA(((2*C+H+L)/4-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,8);

BA:=EMA(AB,5);

頂1:=REFDATE(REF(HHV(H,100),5),DATE);

底1:=REFDATE(REF(LLV(L,100),5),DATE);

中1:=((頂1)+(底1))/2;

頂:IF(AB>0 AND AB-BA<=0,頂1,頂1),COLOR00FF00;

中:IF(AB>0 AND AB-BA<=0,中1,中1),COLORWHITE;

底:IF(AB>0 AND AB-BA<=0,底1,底1),COLORYELLOW;

DRAWTEXT(ISLASTBAR,(頂),STRCAT('',CON2STR(頂,2))),COLORWHITE;

DRAWTEXT(ISLASTBAR,(中),STRCAT('',CON2STR(中,2))),COLORWHITE;

DRAWTEXT(ISLASTBAR,(底),STRCAT('',CON2STR(底,2))),COLORWHITE;

{百底公式2}

N:100 NODRAW ;

高:IF(CURRBARSCOUNT<=N,CONST(HHV(H,N)),DRAWNULL),COLORGREEN ;

低:IF(CURRBARSCOUNT<=N,CONST(LLV(L,N)),DRAWNULL),COLORYELLOW;

NOTEXT中:低+(高-低)/2 COLORWHITE;

{漲幅:(C-低)/低*100 NODRAW COLORFF00FF;}

漲幅:((C-低)/(高-低))*100 NODRAW COLORFF00FF;

漲天數:LLVBARS(L,100)COLORWHITE NODRAW;

{跌幅:((C-高)/高)*100 NODRAW COLORD9D919;};

跌幅:((C-高)/(高-低))*100 NODRAW COLORD9D919;

跌天數:HHVBARS(H,100)COLORWHITE NODRAW;

DRAWTEXT(ISLASTBAR,(高-(高-低)/50),STRCAT('',CON2STR(高-(高-低)/50,2))),COLORWHITE;

DRAWTEXT(ISLASTBAR,(NOTEXT中),STRCAT('',CON2STR(NOTEXT中,2))),COLORWHITE;

DRAWTEXT(ISLASTBAR,(低),STRCAT('',CON2STR(低,2))),COLORWHITE;

MA5:MA(C,5),COLORYELLOW;

NOTEXT5:IF((C<=MA5 OR MA5<=REF(MA5,1)),MA5,DRAWNULL),COLORFFFF00;

振幅:((高-低)/低)*100 NODRAW COLORGREEN;

均周月:INBLOCK('均周')AND INBLOCK('均月') COLORWHITE NODRAW;

逃周月:INBLOCK('逃周')AND INBLOCK('逃月')NODRAW COLORYELLOW;

{VAR6:=REF(C,1);

VAR7:=SMA(MAX(C-VAR6,0),6,1)/SMA(ABS(C-VAR6),6,1)*100;

DRAWTEXT(CROSS(82,VAR7),H*1.01,'高拋'),COLORFFFFFF;

VAR1:=LLV(LOW,21);

VAR2:=HHV(HIGH,21);

AK1:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 100),5);

AK:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 50),13);

AB:=CROSS(AK1,AK);

DRAWTEXT((AB = 1),(LOW * 0.99),'低吸'),COLORYELLOW;};

{百底距:=((C-低)/低)*100;

XG1:=BETWEEN(C,低,低*(1+0.03));

盤整天:BARSLASTCOUNT(XG1)NODRAW COLORYELLOW;}

{上漲值:=MA((H+REF(L,1))/2,3);

買進高點:=MA((H+REF(H,1))/2,3);

VAR1:=((O+H+L+2*C)/5)*2-L;

突破買入值:=MA(VAR1,3);{LSS軸點突破買入值}

{下跌值:=MA((REF(H,1)+L)/2,3);

賣出低點:=MA((REF(L,1)+L)/2,3);

VAR2:=((O+H+L+2*C)/5)*2-H;

突破賣出值:=MA(VAR2,3);

次日賣出點:=(上漲值+買進高點+突破買入值+H)/4;

次日買入點:=(下跌值+賣出低點+突破賣出值+L)/4;

均價:=(2*C+L+H/4);

買入價:IF(均價/REF(均價,1)>1,次日買入點*1.01,次日買入點)COLORWHITE NODRAW;

次低價:IF(均價/REF(均價,1)>1,次日買入點/1.0382,次日買入點)NODRAW COLORYELLOW;

賣出價:IF(均價/REF(均價,1)>1,次日賣出點*1.0191,次日賣出點)NODRAW;

必賣價:IF(均價/REF(均價,1)>1,次日賣出點*1.05,次日賣出點)COLORD9D919 NODRAW;}

{AC:=REF(C,1);

漲停K線:=IF((C-AC)*100/AC>=(10-0.01*100/AC),1,0);

跌停K線:=IF((AC-C)*100/AC>=(10-0.01*100/AC),1,0);

STICKLINE(漲停K線,OPEN,CLOSE,2.5,0),COLORYELLOW;

STICKLINE(跌停K線,OPEN,CLOSE,2.5,0),COLORED9564;}

{漲停顏色粉色,完美區分20%10%5%,創業板20200823前10%照樣變色}

BK:=IF(INBLOCK('科創板'),0.2,IF(INBLOCK('創業板'),0.2,IF(INBLOCK('ST板塊'),0.05,0.1)));

XA_1:=IF(DATE<=1200823,1,0);

STICKLINE((C>=ZTPRICE(REF(CLOSE,1),0.1) AND C=H) AND XA_1=1,O,C,3,0),COLORYELLOW;

STICKLINE((C<=DTPRICE(REF(CLOSE,1),0.1) AND C=L) AND XA_1=1,O,C,3,0),COLORED9564;

STICKLINE((C>=ZTPRICE(REF(C,1),BK) AND C=H),C,O,3,0),COLORYELLOW;

STICKLINE((C<=DTPRICE(REF(C,1),BK) AND C=L),C,O,3,0),COLORED9564;

{STICKLINE((H>=ZTPRICE(REF(C,1),BK) AND C<H) OR (H>=ZTPRICE(REF(CLOSE,1),0.1) AND C<H AND XA_1=1),H,MAX(C,O),0.1,0),COLORYELLOW;{漲停後回落}

{STICKLINE((L<=DTPRICE(REF(C,1),BK) AND C>L) OR (L<=DTPRICE(REF(CLOSE,1),0.1) AND C>L AND XA_1=1),L,MIN(C,O),0.1,0),COLORED9564;{跌停後回升}

{Z1:=STRCAT(HYBLOCK,' ');

Z2:=STRCAT(Z1,DYBLOCK);

Z3:=STRCAT(Z2,' ');

DRAWTEXT_FIX(ISLASTBAR,0,10,0,STRCAT(Z3,GNBLOCK)),COLORWHITE;}

{DRAWTEXT_FIX(1,0.00,0.00,0,'主題投資:')COLORYELLOW;

DRAWTEXT_FIX(1,0.06,0.00,0,EXTERNSTR(0,1))COLORYELLOW;

DRAWTEXT_FIX(1,0.00,0.06,0,'主營業務:')COLORWHITE;

DRAWTEXT_FIX(1,0.06,0.06,0,EXTERNSTR(0,2))COLORWHITE;

DRAWTEXT_FIX(1,0.00,0.12,0,'公司亮點:')COLORYELLOW;

DRAWTEXT_FIX(1,0.06,0.12,0,EXTERNSTR(0,3))COLORYELLOW; }

{流通市值:(FINANCE(40)/100000000),NODRAW,COLORRED;}

{漲停統計}

{漲停:=CLOSE/REF(CLOSE,1)>=1.095;

ZTCS:=COUNT(漲停,BARSSINCE(漲停)+1);}

{DRAWNUMBER(漲停,HIGH*1.04,ZTCS),COLORYELLOW;}

{GZT1:=STRCAT('共漲停: ',CON2STR(ZTCS,0));

GZT2:=STRCAT(GZT1,'次');

SSTS1:=STRCAT('上市: ',CON2STR(FINANCE(42),0));

SSTS2:=STRCAT(SSTS1,'天');

NTZZT1:=STRCAT('距今:',CON2STR(CONST(BARSLAST(漲停)),0));

NTZZT2:=STRCAT(NTZZT1,'天有漲停');

ZTTJ1:=STRCAT(SSTS2,GZT2);

ZTTJ2:=STRCAT(ZTTJ1,NTZZT2);

ZTTJ:=STRCAT('漲停統計:',ZTTJ2);

DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0.18,0,ZTTJ),COLORWHITE;}。

⑷ 誰有東方財富金融終端的趨勢DK線公式源碼

東方財富金融終端的趨勢DK線公式源碼從未公布過,所以目前無法通過網路途徑查詢到會東方財富金融終端的趨勢DK線公式源碼的相關情況,傳出來關於代碼的信息應該是不真實的,有可能是一些炒股的程序員自行些的模擬終端的趨勢DK線公式源碼,只是模擬出未來可能出現的趨勢,切勿盲目進行投資以免造成損失無法彌補。
拓展資料
一、DK線的簡介
dk點用於判斷在盤中買入和賣出的時間點,其中d是買點,k是賣點,用於在macd線上顯示,該功能以紅色趨勢dk線表示主力資金進入流入階段,藍色趨勢dk線表示主力資金進入流出階段,所以可以利用dk點來分析個股,尋找買賣機會,當dk線發出d信號時,是一種買入信號,投資者可以考慮買入一些,當dk線發出K信號時,是一種買出信號,投資者可以考慮賣出一些,或者繼續空倉觀望。不只只利用dk點來分析個股,還可以結合其他技術指標一起分析,增加其發出信號的准確性,當dk線出現d信號時,其中macd指標、kdj指標出現金叉現象,則其買入信號更強,反之當dk線出現k信號時,其中macd指標、kdj指標出現死叉現象,則其賣出信號更強。
二、股票投資策略
1 當有更好的投資機會:准確預測價格走勢的底部和頂部是投資者的理想選擇,但在現實中很難做到。因此,更好的策略不是判斷哪裡是頂部,哪裡是底部,而是一旦確定找到更好的投資機會,就隨時拋出原始股票並購買新股票。
2 調整投資組合時:股票投資的成敗主要取決於如何分配資金比例。只有採用合理的投資組合才能穩贏,投資組合要定期調整。例如,您可能決定將三分之一的資金投資於高科技股票,三分之一投資於低市盈率股票,三分之一投資於小盤股。數月後,由於占資金半壁江山的高科技股市值上漲,可能需要減持高科技股,將資金補充到其他板塊。

⑸ 怎麼看通達信雙龍會主圖指標(源碼)

看通達信雙龍會主圖指標(源碼)的方法:
打開通達信軟體,然後有主圖跟副圖,副圖上有很多指標,選擇好你平時常用的指標,然後再指標上比如rsi,或者kdi等等,在它們的上面點擊右鍵,就可以看到指標設置,指標源碼,你點擊指標源碼確認,就可以看到所有的源代碼啦!

⑹ 如何導出通達信自編指標的源碼

在通達信打開公式管理器 選擇你要導出的指標 選擇快速導出 選擇要保存的位置 問是否完全加密 選擇否 這樣就導出自編指標的源碼了,或者直接復制粘貼指標中的源碼到文本文檔也可以.

⑺ 200分懸賞這個指標的源碼,要同花順和大智慧的.

這個是大智慧版,和樓主的同花順略有不同只要是在大智慧上有些函數不一樣
V8:=600*(EMA(C,3)-EMA(L,30))/EMA(L,30);
V9:=EMA(V8,7);
VA:=(WINNER(120*C/100)-WINNER(100*C/100))*100;
VB:=(-100)*(WINNER(120*C/100)-WINNER(100*C/100))+5;
底買入: IF(VA+VB< 7 AND CROSS(V8,V9) AND V9< -18 AND V9< VB,60,50);
VC:=(2*C+H+L)/4;
VD:=LLV(L,34);
VE:=HHV(H,34);
VF:=LLV(L,21);
V10:=HHV(H,21);
V11:=EMA((VC-VF)/(V10-VD)*100,5);
V12:=EMA((VC-VD)/(VE-VD)*100,8);
X:V11,colorwhite;
頂區:V12;
STICKLINE(V11-V12+20>=20 ,V11-V12+20 ,20 ,5 ,0 ),COLORF000FF;
V13:=EMA(V12,5);
STICKLINE(V12>0 AND (V12-V13)>=0 ,80 ,78 ,6 ,0 ),COLORRED;
STICKLINE(V12>0 AND (V12-V13)<0 ,80 ,78 ,6 ,1 ),COLORBLUE;
STICKLINE(V12>0 AND (V12-V13)>=0 ,20 ,18 ,6 ,0 ),COLORRED;
STICKLINE(V12>0 AND (V12-V13)<0 ,20 ,18 ,6 ,1 ),COLORBLUE;
STICKLINE(V12>V13 , V12,V13,15 ,1 ),COLORGREEN;
0;

⑻ 求文檔: 經傳主力控盤指標通達信源碼

{N 1 300 35
M 1 500 35
N1 1 1000 3}
B1:=(HHV(H,N)-C)/(HHV(H,N)-LLV(LOW,N))*100- M;
B2:=SMA(B1,N,1)+100;
B3:=(C-LLV(L,N))/(HHV(H,N)- LLV(L,N))*100;
B4:=SMA(B3,3,1);
B5:=SMA(B4,3,1)+100;
B6:=B5-B2;
控盤程度:(IF(B6>N1,B6-N1,0))*2.5,COLORYELLOW;
控盤度:100,COLORRED;
STICKLINE( 控盤程度,0,控盤程度 ,7,0 ),COLOR00FFFF;
STICKLINE( 控盤程度 AND 控盤程度>100,100,控盤程度 ,7,0 ),COLORRED;

這個是網上現在流傳的經傳主力控盤源碼。主要是模仿了指標的形態,指標的內在演算法是完全偏離不真實的。

熱點內容
什麼事密碼無條件安全 發布:2022-12-09 15:15:07 瀏覽:214
u盤網卡怎麼關掉自動配置 發布:2022-12-09 15:14:59 瀏覽:986
安卓p代表什麼意思 發布:2022-12-09 15:14:01 瀏覽:684
zfb腳本 發布:2022-12-09 15:10:52 瀏覽:701
電腦無法安裝ug伺服器 發布:2022-12-09 15:08:52 瀏覽:726
批處理訪問共享 發布:2022-12-09 15:08:49 瀏覽:532
編譯ONLYOFFIXE 發布:2022-12-09 15:06:42 瀏覽:17
cftp刪除文件 發布:2022-12-09 15:05:05 瀏覽:439
c語言時間減 發布:2022-12-09 15:05:04 瀏覽:94
電腦時間設置時rpc伺服器不可用 發布:2022-12-09 15:04:51 瀏覽:518