當前位置:首頁 » 操作系統 » 大智慧ts源碼

大智慧ts源碼

發布時間: 2022-09-28 09:56:16

A. 大智慧底部構成源碼及選股公式

要說出底部的技術含義才能寫啊

B. 大智慧主力進出線指標的源碼代碼與計算方法

{主力進出 N:1,100,8;M:1,100,13:1,100,60;S:1,100,3}
V1:=(C*2+H+L)/4*10;
V2:=EMA(V1,13)-EMA(V1,34);
V3:=EMA(V2,5);
V4:=2*(V2-V3)*5.5;
主力開始出: IF(V4<=0,V4,0),COLOR00FF00,LINETHICK2;
主力開始進: IF(V4>=0,V4,0),COLORFF00FF,LINETHICK2;
V5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;
V6:=EMA(3*V5-2*SMA(V5,18,1),5);
V7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10;
V8:=(INDEXC*2+INDEXH+INDEXL)/4;
V9:=EMA(V8,13)-EMA(V8,34);
VA:=EMA(V9,3);
VB:=(V9-VA)/2;
大資金進場: IF(VB>=0,VB,0),COLORRED,LINETHICK2;
大資金撤走: IF(VB<=0,VB,0),COLORBLUE,LINETHICK2; 答案被採納可獲得懸賞分和額外20分獎勵。

C. 這一句大智慧的副圖源碼如何修改才能在通達信軟體里測試通過呢

最好發全碼或明確『趨勢』的完整條件。
改為通達信的源碼如下:

DRAWBAND((趨勢>=REF(趨勢,1)),RGB(255,0,0),(趨勢<REF(趨勢,1)),RGB(0,255,0));
{大於或等於趨勢為紅色帶狀線;小於趨勢為綠色帶狀線。}

D. 求大智慧全套指標公式源碼

這是整個大智慧指標公式的目錄,裡面應該會有適合你的指標,所以可以自行挑選,因為不清楚你的需求是什麼。

E. 求高手將大智慧指標修改成通達信指標,源碼如下,謝謝!!

MID : MA(CLOSE,N);
UPPER: MID + P*STD(CLOSE,N);
LOWER: MID - P*STD(CLOSE,N);

M5:MA(C,5);

M10:MA(C,10),COLORYELLOW;
IF(m5,m5>=REF(m5,1),RGB(255,0,255),m5<=REF(m5,1),RGB(255,255,0)),LINETHICK1;
STICKLINE( O<=MID AND C>=MID AND V>=MA(V,5),OPEN,(C+O)/2,5,0),COLORRED;
STICKLINE(C>=MID AND V>=REF(V,1)*2,OPEN,(C+O)/2,5,0),COLORRED;
IF(m10,m10>=REF(m10,1),RGB(255,0,0),m10<=REF(m10,1),RGB(50,210,20)),LINETHICK1;

F. 請將大智慧預警公式源碼改成通達信的預警公式

通達信預警只能日線啊!

KP30:=1;
KPGD:=H=HHV(H,0) AND KP30;
GDSJ:=BARSLAST(KPGD);
HH:=REF(H,GDSJ);
過頂:IF(CROSS(C,HH),1,0);

這樣就可以

G. 高分:公式修改為大智慧,以下是其源碼

AAA:=(MA(CLOSE,13)+MA(CLOSE,17))/2;
CCC:=(STD(CLOSE,13)+STD(CLOSE,17))/2;
BBB:=AAA+2.1*CCC;
DDD:=AAA+0.72*CCC;
ZZZ:=IF(CCC>1.88 ,MA(DDD,3),DDD);
止贏:ZZZ*1.1,COLORFFCC18;
了結:ZZZ*1.05,COLORFF18FF;
回檔:ZZZ*0.95,COLOR18FF18;
反彈:ZZZ*0.9,COLOR18CCFF;
平衡:ZZZ,COLORFFFFFF;
DRAWTEXT(BARSTATUS=2,止贏,'止贏'),COLORFFCC18;
DRAWTEXT(BARSTATUS=2,了結,'了結'),COLORFF18FF;
DRAWTEXT(BARSTATUS=2,回檔,'回檔'),COLOR18FF18;
DRAWTEXT(BARSTATUS=2,反彈,'反彈'),COLOR18CCFF;
DRAWTEXT(BARSTATUS=2,平衡,'平衡'),COLORFFFFFF;

RSV:=(C-LLV(L,25))/(HHV(HIGH,25)-LLV(L,25))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
VAR6:=(2*C+H+L)/4;{可將3該為4,信號少點}
VAR7:=EMA(EMA(EMA(VAR6,4),4),4);{可將3該為4,信號少點}
VAR8:=(VAR7-REF(VAR7,1))/REF(VAR7,1)*100;
VAR9:=MA(VAR8,3)+0.03;
VAR10:=MA(VAR8,1);
KB:=EMA(C,3)-EMA(C,18);
DB:=EMA(KB,3);
AA:=BARSCOUNT(C);
AH:=HHV(H,120);
AL:=LLV(L,120);
A0:=(AH-AL)/30;
VAR2S:=(2*CLOSE+HIGH+LOW)/4;
VAR3S:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR4S:=LLV(LOW,5);
VAR5S:=HHV(HIGH,4);
散戶:=EMA((VAR2S-VAR4S)/(VAR5S-VAR4S)*100,4)*VAR3S;
莊家:=EMA(0.667*REF(散戶,1)+0.333*散戶,2)*VAR3S;
DRAWTEXT((AA+0)/34=FLOOR((AA+0)/34),L*1,'時間窗'),COLORFFFFFF;
DRAWTEXT(CROSS(散戶,莊家) AND 散戶<30,L*1,'吸'),COLORFF00FF;
DRAWICON(CROSS(VAR9,VAR10) AND J>65,H*1,15),COLORGREEN;
DRAWTEXT(CROSS(VAR9,VAR10) AND J>65,H*1,' 賣'),COLORYELLOW;
DRAWTEXT(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L*1,'地量買點'),COLOR33FFFF;
----------------------------------------------------------

H. 如何導入大智慧公式源碼

大智慧公式原碼導入方法(圖示教程)
2.jpg 4.jpg 6.jpg 一、大智慧上:
1. 把要導入的公式(源碼)復制下來:方法是用左鍵先把源碼變藍,之後點右鍵,點復制;
2. 進入大智慧-->特色功能-->自編指標-->常用-->技術指標-->新建,在出現的公式編輯區的下面的空白處,把剛考的源碼粘貼上,將公式名稱復制後粘貼到公式名稱欄-->確認-->退出;
3.如有參數的,如:N 1 100 15 之類,則需將這類數據填充到參數表中;
4.公式源碼以外的內容,如:名稱,說明以及參數等等,凡在{ }以外的,均要刪除,或者用{ }將其括上;
5、在大智慧的底部顯示欄中點擊公式名稱即可看到剛剛導入的公式。公式源碼的引入方法
一、大智慧上:
1. 把要導入的公式(源碼)復制下來:方法是用左鍵先把源碼變藍,之後點右鍵,點復制;
2. 進入大智慧-->特色功能-->自編指標-->常用-->技術指標-->新建,在出現的公式編輯區的下面的空白處,把剛考的源碼粘貼上,將公式名稱復制後粘貼到公式名稱欄-->確認-->退出;
3.如有參數的,如:N 1 100 15 之類,則需將這類數據填充到參數表中;
4.公式源碼以外的內容,如:名稱,說明以及參數等等,凡在{ }以外的,均要刪除,或者用{ }將其括上;
5、在大智慧的底部顯示欄中點擊公式名稱即可看到剛剛導入的公式。

I. 如何看大智慧自編指標的源碼

依次點擊:功能——自編指標--選擇你要的指標雙擊!彈出窗口可以看到源碼,復制就可以了.但不知道你用什麼軟體,源碼不一定通用的!

J. 股票主圖源碼怎麼用 在大智慧中. 有主圖源碼.不知道怎麼設置.

順序點大智慧菜單上的:公式-公式管理-新建,然後在出來的編輯界面給公式取一個名字,如果是主圖則選擇點一下主圖(墨認為副圖),將你的源碼粘帖到下面的編輯框,最後保存就OK了

熱點內容
python如何安裝模塊 發布:2022-11-28 00:16:50 瀏覽:272
網路攻擊源碼 發布:2022-11-28 00:16:48 瀏覽:232
ftp最好 發布:2022-11-28 00:14:24 瀏覽:500
windowsxp怎麼編譯 發布:2022-11-28 00:14:19 瀏覽:764
樹莓派開機腳本 發布:2022-11-28 00:11:22 瀏覽:129
androidlogcat打開 發布:2022-11-28 00:10:21 瀏覽:170
推理密碼為什麼打不開保險箱 發布:2022-11-28 00:09:28 瀏覽:169
安裝程序引擎拒絕訪問 發布:2022-11-28 00:06:02 瀏覽:700
ue4編譯卡死 發布:2022-11-28 00:03:14 瀏覽:260
如何斷點測試存儲過程 發布:2022-11-28 00:02:03 瀏覽:322