當前位置:首頁 » 操作系統 » 網站播放器源碼

網站播放器源碼

發布時間: 2024-05-28 19:23:39

java播放器源代碼。

import javax.media.*;
import java.awt.*;
import java.awt.event.*;
class MediaPlayer extends Frame implements ActionListener,
ControllerListener, ItemListener
{
Player player;
Component vc, cc;
boolean first = true, loop = false;
String currentDirectory;
MediaPlayer (String title)
{
super (title);
addWindowListener
(new WindowAdapter ()
{
public void windowClosing (WindowEvent e) {
// 用戶點擊窗口系統菜單的關閉按鈕
// 調用dispose以執行windowClosed
dispose ();
} public void windowClosed (WindowEvent e) {
if (player != null) player.close ();
System.exit (0);
}
});
Menu m = new Menu ("文件");
MenuItem mi = new MenuItem ("打開");
mi.addActionListener (this);
m.add (mi);
m.addSeparator ();
CheckboxMenuItem cbmi = new CheckboxMenuItem ("循環", false);
cbmi.addItemListener (this);
m.add (cbmi);
m.addSeparator ();
mi = new MenuItem ("退出");
mi.addActionListener (this);
m.add (mi);
MenuBar mb = new MenuBar ();
mb.add (m);
setMenuBar (mb);
setSize (200, 200);
setVisible (true);
}
public void actionPerformed (ActionEvent e)
{
if (e.getActionCommand ().equals ("退出"))
{
// 調用dispose以便執行windowClosed
dispose ();
return;
}
FileDialog fd = new FileDialog (this, "打開媒體文件",
FileDialog.LOAD);
fd.setDirectory (currentDirectory);
fd.show ();
// 如果用戶放棄選擇文件,則返回
if (fd.getFile () == null) return;
currentDirectory = fd.getDirectory ();
if (player != null)
player.close ();
try
{
player = Manager.createPlayer (new MediaLocator ("file:" + fd.getDirectory () + fd.getFile ()));
}
catch (java.io.IOException e2)
{
System.out.println (e2);
return;
}
catch (NoPlayerException e2)
{
System.out.println ("不能找到播放器.");
return;
}
if (player == null)
{
System.out.println ("無法創建播放器.");
return;
}
first = false;
setTitle (fd.getFile ());
player.addControllerListener (this);
player.prefetch ();
}
public void controllerUpdate (ControllerEvent e)
{
// 調用player.close()時ControllerClosedEvent事件出現。
// 如果存在視覺部件,則該部件應該拆除(為一致起見,
// 我們對控制面板部件也執行同樣的操作)
if (e instanceof ControllerClosedEvent)
{
if (vc != null)
{
remove (vc);
vc = null;
}
if (cc != null)
{
remove (cc);
cc = null;
}
return;
}
if (e instanceof EndOfMediaEvent)
{
if (loop)
{
player.setMediaTime (new Time (0));
player.start ();
}
return;
}
if (e instanceof PrefetchCompleteEvent)
{
player.start ();
return;
}
if (e instanceof RealizeCompleteEvent)
{
vc = player.getVisualComponent ();
if (vc != null)
add (vc);
cc = player.getControlPanelComponent ();
if (cc != null)
add (cc, BorderLayout.SOUTH);
pack ();
}
}
public void itemStateChanged (ItemEvent e)
{
loop = !loop;
}
public void paint (Graphics g)
{
if (first)
{
int w = getSize ().width;
int h = getSize ().height;
g.setColor (Color.blue);
g.fillRect (0, 0, w, h);
Font f = new Font ("DialogInput", Font.BOLD, 16);
g.setFont (f);
FontMetrics fm = g.getFontMetrics ();
int swidth = fm.stringWidth ("*** 歡迎 ***");
g.setColor (Color.white);
g.drawString ("*** 歡迎 ***",
(w - swidth) / 2,
(h + getInsets ().top) / 2);
}
// 調用超類Frame的paint()方法,該paint()方法將調用Frame包含的各個容器
// 和部件(包括控制面板部件)的paint()方法。
super.paint (g);
}
// 不執行背景清除操作,以免控制面板部件閃爍
public void update (Graphics g)
{
paint (g);
}
public static void main (String [] args) {
new MediaPlayer ("媒體播放器1.0");
} }

❷ 求音樂播放器java源代碼

import java.applet.*;
import java.awt.*;
import java.awt.event.*;
import java.net.*;

import javax.swing.*;
import java.io.File;

class AudioPlayDemo extends JFrame implements ActionListener {
boolean looping = false;
File file1 = new File("music\\明天會更好.wav");
AudioClip sound1;
AudioClip chosenClip;

JButton playButton = new JButton("播放");
JButton loopButton = new JButton("循環播放");
JButton stopButton = new JButton("停止");
JLabel status = new JLabel("選擇播放文件");
JPanel controlPanel = new JPanel();
Container container = getContentPane();

public AudioPlayDemo() {
try {
sound1 = Applet.newAudioClip(file1.toURL());
chosenClip = sound1;
} catch(OutOfMemoryError e){
System.out.println("內存溢出");
e.printStackTrace();
} catch(Exception e){
e.printStackTrace();
}
playButton.addActionListener(this);
loopButton.addActionListener(this);
stopButton.addActionListener(this);
stopButton.setEnabled(false);

controlPanel.add(playButton);
controlPanel.add(loopButton);
controlPanel.add(stopButton);

container.add(controlPanel, BorderLayout.CENTER);
container.add(status, BorderLayout.SOUTH);

setSize(300, 130);
setVisible(true);
setDefaultCloseOperation(JFrame.EXIT_ON_CLOSE); //關閉窗口時退出程序
}

public void actionPerformed(ActionEvent event) {
if (chosenClip == null) {
status.setText("聲音未載入");
return;
}
Object source = event.getSource(); //獲取用戶洗滌激活的按鈕

if (source == playButton) {
stopButton.setEnabled(true);
loopButton.setEnabled(true);
chosenClip.play();
status.setText("正在播放");
}

if (source == loopButton) {
looping = true;
chosenClip.loop();
loopButton.setEnabled(false);
stopButton.setEnabled(true);
status.setText("正在循環播放");
}
if (source == stopButton) {
if (looping) {
looping = false;
chosenClip.stop();
loopButton.setEnabled(true);
} else {
chosenClip.stop();
}
stopButton.setEnabled(false);
status.setText("停止播放");
}
}
public static void main(String s[]) {
new AudioPlayDemo();
}
}
這功能不齊,不能下載,也不能播放mp3格式音樂,是用來播放wav格式音樂的,(但你可以在千千靜聽里把mp3格式轉換為wav格式)

❸ 網頁音樂播放器HTML源碼

一、在ASPASP.Net MVC音樂播放的HTML代碼網頁。

❹ 網頁音樂播放器HTML源碼

一、在ASPASP.Net MVC音樂播放的HTML代碼網頁。

❺ 求一個易語言網路視頻播放器源碼。

那你提供的那個網址必須是視頻首地址。記住,是那種在瀏覽器中一打開就是直接播放視頻的地址。否則,任何一種編程語言都是無法做到你說的這種直接放入網址即可播放。除非是在編寫的時候寫入了你網址的視頻規則等,才能實現。
如果你的視頻地址是那種一打開就播放的地址的話,就很簡單了,用易語言的視頻支持庫即可。

❻ 易語言視頻播放器源碼

易語言的支持庫常式裡面有,具體打開易語言
如下:
.版本 2
.支持庫 eMMedia
.支持庫 iext2

.程序集 窗口程序集1

.子程序 _播放按鈕_被單擊

媒體播放1.播放 (-1)
媒體播放1.取長度 ()

.子程序 _暫停按鈕_被單擊

.如果 (媒體播放1.取狀態 () = 1)
媒體播放1.暫停 ()
.否則
媒體播放1.播放 (媒體播放1.取位置 ())
.如果結束

.子程序 _停止按鈕_被單擊

媒體播放1.停止 ()

.子程序 _打開_被選擇

通用對話框1.過濾器 = 「媒體文件|*.wav;*.mid;*.avi;*.mpg;*.mp3;*.wmv;*.rm」
.如果真 (通用對話框1.打開 () = 真)
媒體播放1.打開 (通用對話框1.文件名)
.如果 (媒體播放1.是否視頻 () = 真)
_啟動窗口.標題 = 「視頻文件」
.否則
_啟動窗口.標題 = 「聲音文件」
.如果結束

.如果真結束

.子程序 __啟動窗口_創建完畢

播放按鈕.圖片 = 取圖片組圖片 (#圖片組, 0, 取默認底色 ())
暫停按鈕.圖片 = 取圖片組圖片 (#圖片組, 1, 取默認底色 ())
停止按鈕.圖片 = 取圖片組圖片 (#圖片組, 2, 取默認底色 ())

.子程序 _選擇框1_被單擊

.如果 (選擇框1.選中 = 真)
媒體播放1.置句柄 (分組框1.取窗口句柄 ())
.否則
媒體播放1.置句柄 (0)
.如果結束

.子程序 _媒體信息_被選擇
.局部變數 信息文本, 文本型

信息文本 = 「比率:」 + 到文本 (媒體播放1.取比率 ()) + #換行符 + 「總時間:」 + 到文本 (媒體播放1.取總時間 ()) + #換行符 + 「長度:」 + 到文本 (媒體播放1.取長度 ()) + #換行符 + 「播放位置:」 + 到文本 (媒體播放1.取位置 ()) + #換行符 + 「MCI別名:」 + 媒體播放1.取別名 ()
信息框 (信息文本, 0, )

❼ 求一個用html代碼敲出來的網頁音樂播放器源代碼啊

這個音樂播放器代碼,長度(960)及高度(620)可調,多款音樂台自由切換。
以下為代碼:

<div><embed height="620" allownetworking="internal" width="960" allowscriptaccess="never" loop="-1" invokeurls="false" src="http://www.sgwzdh.com/yyzb" type="audio/mpeg" wmode="transparent"><br/></div>

熱點內容
c語言的是什麼意思啊 發布:2024-06-22 14:37:16 瀏覽:176
cf手游買錯裝備如何退款安卓 發布:2024-06-22 14:32:06 瀏覽:380
文件存儲器 發布:2024-06-22 14:23:06 瀏覽:817
銀行考核ftp什麼意思 發布:2024-06-22 14:20:54 瀏覽:628
重慶二手伺服器市場雲主機 發布:2024-06-22 14:19:06 瀏覽:777
域環境下nfs伺服器搭建 發布:2024-06-22 14:10:25 瀏覽:739
壓縮木耳產地 發布:2024-06-22 14:09:25 瀏覽:825
甘肅張掖市移動網路的伺服器地址 發布:2024-06-22 13:56:27 瀏覽:231
網吧電腦虛擬盤伺服器連接失敗 發布:2024-06-22 13:56:26 瀏覽:943
怎麼訪問共享伺服器 發布:2024-06-22 13:49:14 瀏覽:309