當前位置:首頁 » 存儲配置 » 交換機配置文檔的正確命令是什麼

交換機配置文檔的正確命令是什麼

發布時間: 2022-05-11 12:59:08

1. 華為二層交換機基本配置命令有哪些

所有廠家的交換機配置大同小異,最簡單的就是不配置,接上就用。如果你想遠程管理且交換機是可管理的,那就要為交換機配置地址,至少涉及以下命令:1.進入配置模式:config(任意配置命令都需要先進入這個狀態)2.建立vlan(也可以使用原有的vlan1):vlan(建立vlanN,N一般是2~4096的任意值)3.為該vlan配置地址:interfacevlan(進入對vlanN的配置)ipaddress(為該vlan配置一個ip地址和掩碼)exit(退出對該vlan的配置。有些交換機會提供end命令,直接退出配置狀態,就是config狀態)4.ipdefault-gateway(為該交換機建立默認網關,遠程管理需要)5.write或save(保存你的配置)6.showrun(檢查你的配置)然後你需要看很多資料,了解交換機能做什麼,接下來是你要干什麼,最後是結合資料上的對應命令來實現你的目標。

2. 交換機的配置命令

1.在基於IOS的交換機上設置主機名/系統名:
switch(config)# hostname hostname
在基於CLI的交換機上設置主機名/系統名:
switch(enable) set system name name-string

2.在基於IOS的交換機上設置登錄口令:
switch(config)# enable password level 1 password
在基於CLI的交換機上設置登錄口令:
switch(enable) set password
switch(enable) set enalbepass

3.在基於IOS的交換機上設置遠程訪問:

switch(config)# interface vlan 1

switch(config-if)# ip address ip-address netmask

switch(config-if)# ip default-gateway ip-address

在基於CLI的交換機上設置遠程訪問:

switch(enable) set interface sc0 ip-address netmask broadcast-address

switch(enable) set interface sc0 vlan

switch(enable) set ip route default gateway

4.在基於IOS的交換機上啟用和瀏覽CDP信息:

switch(config-if)# cdp enable

switch(config-if)# no cdp enable

為了查看Cisco鄰接設備的CDP通告信息:

switch# show cdp interface [type modle/port]

switch# show cdp neighbors [type mole/port] [detail]

在基於CLI的交換機上啟用和瀏覽CDP信息:

switch(enable) set cdp {enable|disable} mole/port

為了查看Cisco鄰接設備的CDP通告信息:

switch(enable) show cdp neighbors[mole/port] [vlan|plex|capabilities|detail]

5.基於IOS的交換機的埠描述:

switch(config-if)# description description-string

基於CLI的交換機的埠描述:

switch(enable)set port name mole/number description-string

6.在基於IOS的交換機上設置埠速度:

switch(config-if)# speed{10|100|auto}

在基於CLI的交換機上設置埠速度:

switch(enable) set port speed moudle/number {10|100|auto}

switch(enable) set port speed moudle/number {4|16|auto}

7.在基於IOS的交換機上設置乙太網的鏈路模式:

switch(config-if)# plex {auto|full|half}

在基於CLI的交換機上設置乙太網的鏈路模式:

switch(enable) set port plex mole/number {full|half}

8.在基於IOS的交換機上配置靜態VLAN:

switch# vlan database

switch(vlan)# vlan vlan-num name vla

switch(vlan)# exit

switch# configure teriminal

switch(config)# interface interface mole/number

switch(config-if)# switchport mode access

switch(config-if)# switchport access vlan vlan-num

switch(config-if)# end

在基於CLI的交換機上配置靜態VLAN:

switch(enable) set vlan vlan-num [name name]

switch(enable) set vlan vlan-num mod-num/port-list

9. 在基於IOS的交換機上配置VLAN中繼線:

switch(config)# interface interface mod/port

switch(config-if)# switchport mode trunk

switch(config-if)# switchport trunk encapsulation {isl|dotlq}

switch(config-if)# switchport trunk allowed vlan remove vlan-list

switch(config-if)# switchport trunk allowed vlan add vlan-list

在基於CLI的交換機上配置VLAN中繼線:

switch(enable) set trunk mole/port [on|off|desirable|auto|nonegotiate]

Vlan-range [isl|dotlq|dotl0|lane|negotiate]

10.在基於IOS的交換機上配置VTP管理域:

switch# vlan database

switch(vlan)# vtp domain domain-name

在基於CLI的交換機上配置VTP管理域:

switch(enable) set vtp [domain domain-name]

11.在基於IOS的交換機上配置VTP 模式:

switch# vlan database

switch(vlan)# vtp domain domain-name

switch(vlan)# vtp {sever|cilent|transparent}

switch(vlan)# vtp password password

在基於CLI的交換機上配置VTP 模式:

switch(enable) set vtp [domain domain-name] [mode{ sever|cilent|transparent }][password password]

12. 在基於IOS的交換機上配置VTP版本:

switch# vlan database

switch(vlan)# vtp v2-mode

在基於CLI的交換機上配置VTP版本:

switch(enable) set vtp v2 enable

13. 在基於IOS的交換機上啟動VTP剪裁:

switch# vlan database

switch(vlan)# vtp pruning

在基於CL I 的交換機上啟動VTP剪裁:

switch(enable) set vtp pruning enable

14.在基於IOS的交換機上配置以太信道:

switch(config-if)# port group group-number [distribution {source|destination}]

在基於CLI的交換機上配置以太信道:

switch(enable) set port channel moudle/port-range mode{on|off|desirable|auto}

15.在基於IOS的交換機上調整根路徑成本:

switch(config-if)# spanning-tree [vlan vlan-list] cost cost

在基於CLI的交換機上調整根路徑成本:

switch(enable) set spantree portcost moudle/port cost

switch(enable) set spantree portvlancost moudle/port [cost cost][vlan-list]

16.在基於IOS的交換機上調整埠ID:

switch(config-if)# spanning-tree[vlan vlan-list]port-priority port-priority

在基於CLI的交換機上調整埠ID:

switch(enable) set spantree portpri {mlle/port}priority

switch(enable) set spantree portvlanpri {mole/port}priority [vlans]

17. 在基於IOS的交換機上修改STP時鍾:

switch(config)# spanning-tree [vlan vlan-list] hello-time seconds

switch(config)# spanning-tree [vlan vlan-list] forward-time seconds

switch(config)# spanning-tree [vlan vlan-list] max-age seconds

在基於CLI的交換機上修改STP時鍾:

switch(enable) set spantree hello interval[vlan]

switch(enable) set spantree fwddelay delay [vlan]

switch(enable) set spantree maxage agingtiame[vlan]

18. 在基於IOS的交換機埠上啟用或禁用Port Fast 特徵:

switch(config-if)#spanning-tree portfast

在基於CLI的交換機埠上啟用或禁用Port Fast 特徵:

switch(enable) set spantree portfast {mole/port}{enable|disable}

19. 在基於IOS的交換機埠上啟用或禁用UplinkFast 特徵:

switch(config)# spanning-tree uplinkfast [max-update-rate pkts-per-second]

在基於CLI的交換機埠上啟用或禁用UplinkFast 特徵:

switch(enable) set spantree uplinkfast {enable|disable}[rate update-rate] [all-protocols off|on]

20. 為了將交換機配置成一個集群的命令交換機,首先要給管理介面分配一個IP地址,然後使用下列命令: switch(config)# cluster enable cluster-name cv

3. 交換機的基本命令是什麼

「Switch>」

4. 這個交換機配置命令是何意思

交換機基本配置命令(3026)

PCA login: root ;使用root用戶
password: linux ;口令是linux
# shutdown -h now ;關機
# init 0 ;關機
# logout
# login
# ifconfig ;顯示IP地址
# ifconfig eth0 <ip address> netmask <netmask> ;設置IP地址
# ifconfig eht0 <ip address> netmask <netmask> down ; 刪除IP地址
# route add 0.0.0.0 gw <ip>
# route del 0.0.0.0 gw <ip>
# route add default gw <ip> ;設置網關
# route del default gw <ip> ;刪除網關
# route ;顯示網關
# ping <ip>
# telnet <ip> ;建議telnet之前先ping一下

----------------------------------------
交換機命令
~~~~~~~~~~
[Quidway]super password 修改特權用戶密碼
[Quidway]sysname 交換機命名
[Quidway]interface ethernet 0/1 進入介面視圖
[Quidway]interface vlan x 進入介面視圖
[Quidway-Vlan-interfacex]ip address 10.65.1.1 255.255.0.0
[Quidway]ip route-static 0.0.0.0 0.0.0.0 10.65.1.2 靜態路由=網關

[Quidway]user-interface vty 0 4
[S3026-ui-vty0-4]authentication-mode password
[S3026-ui-vty0-4]set authentication-mode password simple 222
[S3026-ui-vty0-4]user privilege level 3

[Quidway-Ethernet0/1]plex {half|full|auto} 配置埠雙工工作狀態
[Quidway-Ethernet0/1]speed {10|100|auto} 配置埠工作速率
[Quidway-Ethernet0/1]flow-control 配置埠流控
[Quidway-Ethernet0/1]mdi {across|auto|normal} 配置埠MDI/MDIX狀態平接或扭接
[Quidway-Ethernet0/1]port link-type {trunk|access|hybrid} 設置介面工作模式
[Quidway-Ethernet0/1]shutdown 關閉/重起介面
[Quidway-Ethernet0/2]quit 退出系統視圖

[Quidway]vlan 3 創建/刪除一個VLAN/進入VLAN模式
[Quidway-vlan3]port ethernet 0/1 to ethernet 0/4 在當前VLAN增加/刪除乙太網介面
[Quidway-Ethernet0/2]port access vlan 3 將當前介面加入到指定VLAN
[Quidway-Ethernet0/2]port trunk permit vlan {ID|All} 設trunk允許的VLAN
[Quidway-Ethernet0/2]port trunk pvid vlan 3 設置trunk埠的PVID

[Quidway]monitor-port <interface_type interface_num> 指定和清除鏡像埠
[Quidway]port mirror <interface_type interface_num> 指定和清除被鏡像埠
[Quidway]port mirror int_list observing-port int_type int_num 指定鏡像和被鏡像

[Quidway]description string 指定VLAN描述字元
[Quidway]description 刪除VLAN描述字元
[Quidway]display vlan [vlan_id] 查看VLAN設置

[Quidway]stp {enable|disable} 開啟/關閉生成樹,默認關閉
[Quidway]stp priority 4096 設置交換機的優先順序
[Quidway]stp root {primary|secondary} 設置交換機為根或根的備份
[Quidway-Ethernet0/1]stp cost 200 設置交換機埠的花費

[SwitchA-vlanx]isolate-user-vlan enable 設置主vlan
[SwitchA]Isolate-user-vlan <x> secondary <list> 設置主vlan包括的子vlan
[Quidway-Ethernet0/2]port hybrid pvid vlan <id> 設置vlan的pvid
[Quidway-Ethernet0/2]port hybrid pvid 刪除vlan的pvid
[Quidway-Ethernet0/2]port hybrid vlan vlan_id_list untagged 設置無標識的vlan
如果包的vlan id與PVId一致,則去掉vlan信息. 默認PVID=1。
所以設置PVID為所屬vlan id, 設置可以互通的vlan為untagged.
----------------------------------------
路由器命令
~~~~~~~~~~
[Quidway]display version 顯示版本信息
[Quidway]display current-configuration 顯示當前配置
[Quidway]display interfaces 顯示介面信息
[Quidway]display ip route 顯示路由信息

[Quidway]sysname aabbcc 更改主機名
[Quidway]super passwrod 123456 設置口令
[Quidway]interface serial0 進入介面
[Quidway-serial0]ip address <ip><mask>
[Quidway-serial0]undo shutdown 激活埠
[Quidway]link-protocol hdlc 綁定hdlc協議
[Quidway]user-interface vty 0 4
[Quidway-ui-vty0-4]authentication-mode password
[Quidway-ui-vty0-4]set authentication-mode password simple 222
[Quidway-ui-vty0-4]user privilege level 3
[Quidway-ui-vty0-4]quit

[Quidway]debugging hdlc all serial0 顯示所有信息
[Quidway]debugging hdlc event serial0 調試事件信息
[Quidway]debugging hdlc packet serial0 顯示包的信息

靜態路由:
[Quidway]ip route-static <ip><mask>{interface number|nexthop}[value][reject|blackhole]
例如:
[Quidway]ip route-static 129.1.0.0 16 10.0.0.2
[Quidway]ip route-static 129.1.0.0 255.255.0.0 10.0.0.2
[Quidway]ip route-static 129.1.0.0 16 Serial 2
[Quidway]ip route-static 0.0.0.0 0.0.0.0 10.0.0.2

動態路由:
[Quidway]rip
[Quidway]rip work
[Quidway]rip input
[Quidway]rip output
[Quidway-rip]network 1.0.0.0 ;可以all
[Quidway-rip]network 2.0.0.0
[Quidway-rip]peer ip-address
[Quidway-rip]summary
[Quidway]rip version 1
[Quidway]rip version 2 multicast
[Quidway-Ethernet0]rip split-horizon ;水平分隔

[Quidway]router id A.B.C.D 配置路由器的ID
[Quidway]ospf enable 啟動OSPF協議
[Quidway-ospf]import-route direct 引入直聯路由
[Quidway-Serial0]ospf enable area <area_id> 配置OSPF區域

標准訪問列表命令格式如下:
acl <acl-number> [match-order config|auto] 默認前者順序匹配。
rule [normal|special]{permit|deny} [source source-addr source-wildcard|any]
例:
[Quidway]acl 10
[Quidway-acl-10]rule normal permit source 10.0.0.0 0.0.0.255
[Quidway-acl-10]rule normal deny source any

擴展訪問控制列表配置命令

配置TCP/UDP協議的擴展訪問列表:
rule {normal|special}{permit|deny}{tcp|udp}source {<ip wild>|any}destination <ip wild>|any}
[operate]

配置ICMP協議的擴展訪問列表:
rule {normal|special}{permit|deny}icmp source {<ip wild>|any]destination {<ip wild>|any]
[icmp-code] [logging]

擴展訪問控制列表操作符的含義
equal portnumber 等於
greater-than portnumber 大於
less-than portnumber 小於
not-equal portnumber 不等
range portnumber1 portnumber2 區間

擴展訪問控制列表舉例
[Quidway]acl 101
[Quidway-acl-101]rule deny souce any destination any
[Quidway-acl-101]rule permit icmp source any destination any icmp-type echo
[Quidway-acl-101]rule permit icmp source any destination any icmp-type echo-reply

[Quidway]acl 102
[Quidway-acl-102]rule permit ip source 10.0.0.1 0.0.0.0 destination 202.0.0.1 0.0.0.0
[Quidway-acl-102]rule deny ip source any destination any

[Quidway]acl 103
[Quidway-acl-103]rule permit tcp source any destination 10.0.0.1 0.0.0.0 destination-port equal ftp
[Quidway-acl-103]rule permit tcp source any destination 10.0.0.2 0.0.0.0 destination-port equal www

[Quidway]firewall enable
[Quidway]firewall default permit|deny
[Quidway]int e0
[Quidway-Ethernet0]firewall packet-filter 101 inbound|outbound

地址轉換配置舉例
[Quidway]firewall enable
[Quidway]firewall default permit
[Quidway]acl 101
[Quidway-acl-101]rule deny ip source any destination any
[Quidway-acl-101]rule permit ip source 129.38.1.4 0 destination any
[Quidway-acl-101]rule permit ip source 129.38.1.1 0 destination any
[Quidway-acl-101]rule permit ip source 129.38.1.2 0 destination any
[Quidway-acl-101]rule permit ip source 129.38.1.3 0 destination any
[Quidway]acl 102
[Quidway-acl-102]rule permit tcp source 202.39.2.3 0 destination 202.38.160.1 0
[Quidway-acl-102]rule permit tcp source any destination 202.38.160.1 0 destination-port great-than
1024

[Quidway-Ethernet0]firewall packet-filter 101 inbound
[Quidway-Serial0]firewall packet-filter 102 inbound

[Quidway]nat address-group 202.38.160.101 202.38.160.103 pool1
[Quidway]acl 1
[Quidway-acl-1]rule permit source 10.110.10.0 0.0.0.255
[Quidway-acl-1]rule deny source any
[Quidway-acl-1]int serial 0
[Quidway-Serial0]nat outbound 1 address-group pool1

[Quidway-Serial0]nat server global 202.38.160.101 inside 10.110.10.1 ftp tcp
[Quidway-Serial0]nat server global 202.38.160.102 inside 10.110.10.2 www tcp
[Quidway-Serial0]nat server global 202.38.160.102 8080 inside 10.110.10.3 www tcp
[Quidway-Serial0]nat server global 202.38.160.103 inside 10.110.10.4 smtp udp

PPP驗證:
主驗方:pap|chap
[Quidway]local-user u2 password {simple|cipher} aaa
[Quidway]interface serial 0
[Quidway-serial0]ppp authentication-mode {pap|chap}
[Quidway-serial0]ppp chap user u1 //pap時,不用此句

pap被驗方:
[Quidway]interface serial 0
[Quidway-serial0]ppp pap local-user u2 password {simple|cipher} aaa

chap被驗方:
[Quidway]interface serial 0
[Quidway-serial0]ppp chap user u1
[Quidway-serial0]local-user u2 password {simple|cipher} aaa
參考資料:http://forum.huawei-3com.com/archiver/?tid-13322.html

5. CISCO交換機的查看配置命令是什麼

1、Router#show startup-config //查看啟動配置文件

啟動配置文件startup-config位於路由器的NVRAM中,可以長期保存。它在啟動路由器時裝入RAM,成為running-config。

2、Router#show version //查看路由器的版本信息

3、Router#show ip interface brief //查看路由器的介面狀態

(5)交換機配置文檔的正確命令是什麼擴展閱讀:

工作在數據鏈路層。交換機擁有一條很高帶寬的背部匯流排和內部交換矩陣。交換機的所有的埠都掛接在這條背部匯流排上,控制電路收到數據包以後,處理埠會查找內存中的地址對照表以確定目的MAC(網卡的硬體地址)的NIC(網卡)掛接在哪個埠上。

通過內部交換矩陣迅速將數據包傳送到目的埠,目的MAC若不存在,廣播到所有的埠,接收埠回應後交換機會「學習」新的地址,並把它添加入內部MAC地址表中。使用交換機也可以把網路「分段」,通過對照MAC地址表,交換機只允許必要的網路流量通過交換機。

通過交換機的過濾和轉發,可以有效的減少沖突域,但它不能劃分網路層廣播,即廣播域。交換機在同一時刻可進行多個埠對之間的數據傳輸。每一埠都可視為獨立的網段,連接在其上的網路設備獨自享有全部的帶寬,無須同其他設備競爭使用。當節點A向節點D發送數據時,節點B可同時向節點C發送數據,而且這兩個傳輸都享有網路的全部帶寬,都有著自己的虛擬連接。

假使這里使用的是10Mbps的乙太網交換機,那麼該交換機這時的總流通量就等於2×10Mbps=20Mbps,而使用10Mbps的共享式HUB時,一個HUB的總流通量也不會超出10Mbps。

總之,交換機是一種基於MAC地址識別,能完成封裝轉發數據包功能的網路設備。交換機可以「學習」MAC地址,並把其存放在內部地址表中,通過在數據幀的始發者和目標接收者之間建立臨時的交換路徑,使數據幀直接由源地址到達目的地址。

6. 交換機的命令具體怎麼使用

交換機的命令非常多,主要是用來配置交換機的,只有可網管的交換機(有console口的交換機)才能進行配置。
不同廠家、不同型號的交換機的配置命令也不大一樣。
舉個CISCO的命令例子吧:
hostname是給交換機命名的命令,如交換機本來的名字是Switch,使用(config)#hostname
JIAOHUANJI,就可以把交換機的名字改成JIAOHUANJI了。
交換機配置時還分很多種模式,每種模式下的配置命令也都有很大區別,具體的真不是三兩句說得清的,你只有買些教材看看了。

7. 交換機配置相關命令是什麼

你那什麼牌子的呀 他的設置大同小類了
我給你幾個 前面是通用的 後面的你自己慢慢研究 不會問我了
交換機基本配置命令(3026)

PCA login: root ;使用root用戶
password: linux ;口令是linux
# shutdown -h now ;關機
# init 0 ;關機
# logout
# login
# ifconfig ;顯示IP地址
# ifconfig eth0 <ip address> netmask <netmask> ;設置IP地址
# ifconfig eht0 <ip address> netmask <netmask> down ; 刪除IP地址
# route add 0.0.0.0 gw <ip>
# route del 0.0.0.0 gw <ip>
# route add default gw <ip> ;設置網關
# route del default gw <ip> ;刪除網關
# route ;顯示網關
# ping <ip>
# telnet <ip> ;建議telnet之前先ping一下
交換機命令
[Quidway]super password 修改特權用戶密碼
[Quidway]sysname 交換機命名
[Quidway]interface ethernet 0/1 進入介面視圖
[Quidway]interface vlan x 進入介面視圖
[Quidway-Vlan-interfacex]ip address 10.65.1.1 255.255.0.0
[Quidway]ip route-static 0.0.0.0 0.0.0.0 10.65.1.2 靜態路由=網關

[Quidway]user-interface vty 0 4
[S3026-ui-vty0-4]authentication-mode password
[S3026-ui-vty0-4]set authentication-mode password simple 222
[S3026-ui-vty0-4]user privilege level 3

[Quidway-Ethernet0/1]plex {half|full|auto} 配置埠雙工工作狀態
[Quidway-Ethernet0/1]speed {10|100|auto} 配置埠工作速率
[Quidway-Ethernet0/1]flow-control 配置埠流控
[Quidway-Ethernet0/1]mdi {across|auto|normal} 配置埠MDI/MDIX狀態平接或扭接
[Quidway-Ethernet0/1]port link-type {trunk|access|hybrid} 設置介面工作模式
[Quidway-Ethernet0/1]shutdown 關閉/重起介面
[Quidway-Ethernet0/2]quit 退出系統視圖

[Quidway]vlan 3 創建/刪除一個VLAN/進入VLAN模式
[Quidway-vlan3]port ethernet 0/1 to ethernet 0/4 在當前VLAN增加/刪除乙太網介面
[Quidway-Ethernet0/2]port access vlan 3 將當前介面加入到指定VLAN
[Quidway-Ethernet0/2]port trunk permit vlan {ID|All} 設trunk允許的VLAN
[Quidway-Ethernet0/2]port trunk pvid vlan 3 設置trunk埠的PVID

[Quidway]monitor-port <interface_type interface_num> 指定和清除鏡像埠
[Quidway]port mirror <interface_type interface_num> 指定和清除被鏡像埠
[Quidway]port mirror int_list observing-port int_type int_num 指定鏡像和被鏡像

[Quidway]description string 指定VLAN描述字元
[Quidway]description 刪除VLAN描述字元
[Quidway]display vlan [vlan_id] 查看VLAN設置

[Quidway]stp {enable|disable} 開啟/關閉生成樹,默認關閉
[Quidway]stp priority 4096 設置交換機的優先順序
[Quidway]stp root {primary|secondary} 設置交換機為根或根的備份
[Quidway-Ethernet0/1]stp cost 200 設置交換機埠的花費

[SwitchA-vlanx]isolate-user-vlan enable 設置主vlan
[SwitchA]Isolate-user-vlan <x> secondary <list> 設置主vlan包括的子vlan
[Quidway-Ethernet0/2]port hybrid pvid vlan <id> 設置vlan的pvid
[Quidway-Ethernet0/2]port hybrid pvid 刪除vlan的pvid
[Quidway-Ethernet0/2]port hybrid vlan vlan_id_list untagged 設置無標識的vlan
如果包的vlan id與PVId一致,則去掉vlan信息. 默認PVID=1。
所以設置PVID為所屬vlan id, 設置可以互通的vlan為untagged.

8. 交換機與路由器的常用配置命令是什麼

1. 交換機支持的命令:
交換機基本狀態: switch: ;ROM狀態,
路由器是rommon>hostname> ;用戶模式hostname# ;特權模式hostname(config)# ;全局配置模式hostname(config-if)# ;介面狀態

交換機口令設置: switch>enable ;進入特權模式
switch#config terminal ;進入全局配置模式
switch(config)#hostname ;設置交換機的主機名
switch(config)#enable secret xxx ;設置特權加密口令
switch(config)#enable password xxa ;設置特權非密口令
switch(config)#line console 0 ;進入控制台口
switch(config-line)#line vty 0 4 ;進入虛擬終端
switch(config-line)#login ;允許登錄
switch(config-line)#password xx ;設置登錄口令
xxswitch#exit ;返回命令

交換機VLAN設置:

switch#vlan database ;進入VLAN設置
switch(vlan)#vlan 2 ;建VLAN 2
switch(vlan)#no vlan 2 ;刪vlan 2
switch(config)#int f0/1 ;進入埠1
switch(config-if)#switchport access vlan 2 ;當前埠加入
vlan 2switch(config-if)#switchport mode trunk ;設置為干線
switch(config-if)#switchport trunk allowed vlan 1,2 ;設置允許的vlan
switch(config-if)#switchport trunk encap dot1q ;設置vlan 中繼
switch(config)#vtp domain ;設置發vtp域名
switch(config)#vtp password ;設置發vtp密碼
switch(config)#vtp mode server ;設置發vtp模式
switch(config)#vtp mode client ;設置發vtp模式

交換機設置IP地址:

switch(config)#interface vlan 1 ;進入vlan 1
switch(config-if)#ip address ;設置IP地址
switch(config)#ip default-gateway ;設置默認網關
switch#dir flash: ;查看快閃記憶體

交換機顯示命令:

switch#write ;保存配置信息
switch#show vtp ;查看vtp配置信息
switch#show run ;查看當前配置信息
switch#show vlan ;查看vlan配置信息
switch#show interface ;查看埠信息
switch#show int f0/0 ;查看指定埠信息

2. 路由器支持的命令:
路由器顯示命令:

router#show run ;顯示配置信息
router#show interface ;顯示介面信息
router#show ip route ;顯示路由信息
router#show cdp nei ;顯示鄰居信息
router#reload ;重新起動

路由器口令設置:

router>enable ;進入特權模式
router#config terminal ;進入全局配置模式
router(config)#hostname ;設置交換機的主機名
router(config)#enable secret xxx ;設置特權加密口令
router(config)#enable password xxb ;設置特權非密口令
router(config)#line console 0 ;進入控制台口
router(config-line)#line vty 0 4 ;進入虛擬終端
router(config-line)#login ;要求口令驗證
router(config-line)#password xx ;設置登錄口令xx
router(config)#(Ctrl+z) ; 返回特權模式
router#exit ;返回命令

路由器配置:

router(config)#int s0/0 ;進入Serail介面
router(config-if)#no shutdown ;激活當前介面
router(config-if)#clock rate 64000 ;設置同步時鍾
router(config-if)#ip address ;設置IP地址
router(config-if)#ip address second ;設置第二個IP
router(config-if)#int f0/0.1 ;進入子介面
router(config-subif.1)#ip address ;設置子介面IP
router(config-subif.1)#encapsulation dot1q ;綁定vlan中繼協議
router(config)#config-register 0x2142 ;跳過配置文件
router(config)#config-register 0x2102 ;正常使用配置文件
router#reload ;重新引導

路由器文件操作:

router# running-config startup-config ;保存配置
router# running-config tftp ;保存配置到tftp
router# startup-config tftp ;開機配置存到tftp
router# tftp flash: ;下傳文件到flash
router# tftp startup-config;下載配置文件ROM狀態:
Ctrl+Break ;進入ROM監控狀態
rommon>confreg 0x2142 ;跳過配置文件
rommon>confreg 0x2102 ;恢復配置文件
rommon>reset ;重新引導
rommon> xmodem: flash: ;從console傳輸文件

rommon>IP_ADDRESS=10.65.1.2 ;設置路由器IP
rommon>IP_SUBNET_MASK=255.255.0.0 ;設置路由器掩碼
rommon>TFTP_SERVER=10.65.1.1 ;指定TFTP伺服器IP
rommon>TFTP_FILE=c2600.bin ;指定下載的文件
rommon>tftpdnld ;從tftp下載
rommon>dir flash: ;查看快閃記憶體內容
rommon>boot ;引導IOS

靜態路由:

ip route ;命令格式router(config)#ip route 2.0.0.0 255.0.0.0 1.1.1.2 ;
靜態路由舉例router(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.2 ;默認路由舉例

動態路由:

router(config)#ip routing ;啟動路由轉發
router(config)#router rip ;啟動RIP路由協議。
router(config-router)#network ;設置發布路由
router(config-router)#negihbor ;點對點幀中繼用。

最好是去官方網站參考手冊。

9. 華為交換機查看配置的命令是什麼

華為交換機常用命令:

1、displaycurrent-configuration顯示當前配置

2、/1/4顯示介面信息

3、displaypacket-/1/4顯示介面acl應用信息

4、displayaclall顯示所有acl設置3900系列交換機

5、displayaclconfigall顯示所有acl設置6500系列交換機

6、displayarp10.78.4.1顯示該ip地址的mac地址,所接交換機的埠位置

7、displaycpu顯示cpu信息

8、system-view進入系統圖(配置交換機),等於configt命令

9、aclnumber5000在system-view命令後使用,進入acl配置狀態

10、在上面的命令後使用,acl配置例子

11、//在上面的命令後使用,acl配置例子

12、interfaceGigabitEthernet1/0/9//在system-view命令後使用,進入介面配置狀態

13、[86ZX-S6503-GigabitEthernet1/0/9]qos//在上面的命令後使用,進入介面qos配置

14、[86ZX-S6503-qosb-GigabitEthernet1/0/9]packet-filterinbounser-group5000//在上面的命令後使用,在介面上應用進站的acl

15、[Build4-2_S3928TP-GigabitEthernet1/1/4]packet-filteroutbounser-group5001//在介面上應用出站的acl

16、undoaclnumber5000//取消aclnumber5000的設置

17、iproute-static0.0.0.00.0.0.010.78.1.1preference60//設置路由

18、/0/14//重置介面信息

19、save//保存設置

20、quit//退出

熱點內容
android和web 發布:2024-05-28 22:24:32 瀏覽:465
演算法前途 發布:2024-05-28 22:13:45 瀏覽:360
vs2008資料庫的連接 發布:2024-05-28 22:12:06 瀏覽:464
sqlserver資料庫的復制 發布:2024-05-28 22:10:31 瀏覽:659
如何看老電腦配置 發布:2024-05-28 22:09:27 瀏覽:77
access資料庫的層次 發布:2024-05-28 21:56:22 瀏覽:308
頁面訪問緊急升級新域名 發布:2024-05-28 21:55:38 瀏覽:725
壓縮機管路 發布:2024-05-28 21:26:07 瀏覽:306
安卓結束腳本 發布:2024-05-28 20:40:08 瀏覽:66
本地ubuntu伺服器搭建 發布:2024-05-28 20:40:03 瀏覽:100